HDU 1515 Anagrams by Stack【深搜】

Problem Description
How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and
Pop - to retrieve the most recently pushed item
We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it's too short), neither is
i i o o o i (there's an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.
Input
The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.
Output
For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by
[
]
and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.
Sample Input
madam adamm bahama bahama long short eric rice
Sample Output
[
i i i i o o o i o o
i i i i o o o o i o
i i o i o i o i o o
i i o i o i o o i o
]
[
i o i i i o o i i o o o
i o i i i o o o i o i o
i o i o i o i i i o o o
i o i o i o i o i o i o
]
[
]
[
i i o i o i o o
]
code:
View Code
#include<stdio.h>
#include<string.h>
char a[222],b[222];
char q[222];
char r[300];
int len1,len2;
void dfs(int top,int rear,int rear1,int rear2)
{
int i;
if(rear2==len2){
for(i=0;i<rear;i++)
printf("%c ",r[i]);
printf("\n");
return;
}
if(rear1<len1){
int x=top+1;
char tt=q[x];
q[x]=a[rear1];
r[rear]='i';
dfs(top+1,rear+1,rear1+1,rear2);
q[x]=tt;
}
if(top>=0&&q[top]==b[rear2])
{
r[rear]='o';
dfs(top-1,rear+1,rear1,rear2+1);
}
}
int main()
{
while(scanf("%s%s",a,b)!=EOF){
len1=strlen(a);
len2=strlen(b);
printf("[\n");
if(len1!=len2){
printf("]\n");
continue;
}
dfs(-1,0,0,0);
printf("]\n");
}
return 0;
}
posted @ 2012-03-30 17:30  'wind  阅读(206)  评论(0编辑  收藏  举报