HD HDU 1312 Red and Black 【深搜】

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includesW characters. Each character represents thecolor of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13
 
code:
View Code
#include<stdio.h>
char s[21][21];
int t,m,n,f[8]={-1,0,0,1, 0,-1,1,0};
void dfs(int i,int j)
{
int ii,jj,p;
for(p=0;p<4;p++)
{
ii=i+f[p];
jj=j+f[p+4];
if(ii>=0&&ii<m&&jj>=0&&jj<n&&s[ii][jj]=='.')
{
s[ii][jj]='#';
t++;
dfs(ii,jj);
}
}
return;
}
int main()
{
int i,j;
while(scanf("%d%d",&n,&m),m||n)
{t=1;
for(i=0;i<m;i++)
scanf("%s",s[i]);
for(i=0;i<m;i++)
for(j=0;j<n;j++)
if(s[i][j]=='@')
{
s[i][j]='#';
dfs(i,j);
}
printf("%d\n",t);
}
return 0;
}

posted @ 2012-03-15 12:34  'wind  阅读(238)  评论(0编辑  收藏  举报