HDU 1686 Oulipo【KMP】

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
分析:KMP入门题,求出模式串在给定字符串出现的次数。
code:
View Code
#include<stdio.h>
#include<string.h>
char m[10001];
char s[1000001];
int next[10001];
int len1,len2,tot;
void getnext()
{
int i=0,j=-1;
next[0]=-1;
while(i<len2) //和上一题的不同之处
{
if(j==-1||m[i]==m[j])
{
i++;j++;
if(m[i]!=m[j])
next[i]=j;
else next[i]=next[j];
}
else j=next[j];
}
}
void kmp()
{
int i=0,j=0;
while(i<len1&&j<len2)
{
if(s[i]==m[j]||j==-1)
{
i++;j++;
}
else j=next[j];
if(j>=len2)
{
tot++;
j=next[j]; //关键的地方!!!!
}
}
}
int main()
{
int i,t;
scanf("%d",&t);
while(t--)
{
scanf("%s%s",m,s);
len1=strlen(s);
len2=strlen(m);
tot=0;
getnext();
kmp();
printf("%d\n",tot);
}
return 0;
}

posted @ 2012-03-14 18:23  'wind  阅读(182)  评论(0编辑  收藏  举报