HDU2222 Keywords Search 【AC自动机】

HDU2222 Keywords Search


Problem Description

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input

First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a’-‘z’, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.

Output

Print how many keywords are contained in the description.

Sample Input

1
5
she
he
say
shr
her
yasherhs

Sample Output

3


AC自动机模板,加一个小优化,在处理失配指针的时候预处理节点经过失配后到达的节点


#include<bits/stdc++.h>
using namespace std;
#define N 1000010
struct Node{
    int fail,cnt,ch[26];
    void clean(){
        fail=cnt=0;
        memset(ch,0,sizeof(ch));
    }   
}t[N];
int tot,n,ans;
bool vis[N];
char s[N];
void init(){
    tot=1;ans=0;
    memset(vis,0,sizeof(vis));
    t[0].clean();t[1].clean();
    for(int i=0;i<26;i++)t[0].ch[i]=1;
}
int index(char c){return c-'a';}
void insert(char *s){
    int len=strlen(s),u=1;
    for(int i=0;i<len;i++){
        int tmp=index(s[i]);
        if(!t[u].ch[tmp])
            t[t[u].ch[tmp]=++tot].clean();
        u=t[u].ch[tmp];
    }
    t[u].cnt++;
}
void buildFail(){
    static queue<int> q;
    q.push(1);
    while(!q.empty()){
        int u=q.front();q.pop();
        for(int i=0;i<26;i++){
            int w=t[u].ch[i],v=t[u].fail;
            while(!t[v].ch[i])v=t[v].fail;
            v=t[v].ch[i];
            if(w){
                t[w].fail=v;
                q.push(w);
            }else t[u].ch[i]=v;//失配预处理
        }
    }
}
void collect(int u){
    while(u&&!vis[u]){
        vis[u]=1;
        ans+=t[u].cnt;
        u=t[u].fail;
    }
}
int main(){
    int T;scanf("%d",&T);
    while(T--){
        init();
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%s",s);
            insert(s);
        }
        buildFail();
        scanf("%s",s);
        int len=strlen(s),u=1;
        for(int i=0;i<len;i++){
            int tmp=index(s[i]);
            u=t[u].ch[tmp];
            collect(u);
        }
        printf("%d\n",ans);
    }
    return 0;
} 
posted @ 2018-06-20 19:44  Dream_maker_yk  阅读(110)  评论(0编辑  收藏  举报