【游戏开发日志】升级node.js依赖包引发的BUG

我们的一款游戏准备上线,这几周大家都在做上线前的准备工作。由于这款游戏开发周期比较长的,服务端用的是node.js开发,其中有几个依赖包比较老,在上线前准备升级一下。

升级包括了crc和async这2个包,没想到这2个常见的包的API有所改动,导致游戏服务器出现BUG,花了半天时间去排查问题。

先是crc,我们用到crc.crc32来计算比较配置文件的差异,在之前的老版本中返回的值是带符号的32位整数,新版本中已经变成无符号的32位整数。

async.auto函数可以根据依赖自动安排异步方法的执行顺序,但是在原来的回调函数的签名是先cb后results,新版本中已经改成先results后cb。

升级依赖包是有一定风险的,进行升级后一定要测试到位。

posted @ 2018-05-25 21:46  doublerain  阅读(176)  评论(0编辑  收藏  举报