arm版本的gdb 库存在,ldd却仍然报错 not found

1.交叉编译环境下的linaro-gdb无法用。

参考:https://stackoverflow.com/questions/25314983/ldd-says-not-found-even-though-library-is-in-my-ld-library-path

交叉编译环境里面gdb报错缺少libncurses.so.5。 而使用ldconfig -p | grep libncurses.so.5 却是能够找到的。

很可能是32位和64位冲突导致,库是64位的,而程序是32位的,可以用file分别确认下。

$ file libpmsfdcwrt.so
libpmsfdcwrt.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, not stripped

$ file /lib64/libz.so.1.2.3
/lib64/libz.so.1.2.3: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped

 

解决方案:下载64位版本的gdb可以解决。官网有的。

 

posted @ 2021-11-24 16:26  dzqabc  阅读(19)  评论(0编辑  收藏  举报