HDU 1017 直接暴力。

C - 3
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer. 

This problem contains multiple test cases! 

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks. 

The output format consists of N output blocks. There is a blank line between output blocks. 

Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100. 

Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below. 

Sample Input

1

10 1
20 3
30 4
0 0

Sample Output

Case 1: 2
Case 2: 4
Case 3: 5


代码:

#include<stdio.h>
#include<string.h>
#include<math.h>

#define N 110


int main()
{
    int i, j, t, n, m, f = 0;

    scanf("%d", &t);

    while(t--)
    {
        int k = 1;

        if(f == 1)
            printf("\n");

        while(scanf("%d%d", &n, &m), n+m)
        {
            int ans=0;

            for(i = 1; i < n; i++)
            {
                for(j = 1; j < n; j++)
                {
                    if((i*i+j*j+m) % (i*j) == 0 && (i < j))
                        ans++;
                }

            }
            printf("Case %d: %d\n", k++,ans);
        }

        f = 1;
    }
    return 0;
}

posted on 2016-08-16 17:22  缄默。  阅读(260)  评论(0编辑  收藏  举报

导航