CUDA、CUDNN在Mac Book Pro上安装的问题

由于原版MacOS自带Nvidia驱动版本过低,导致最新版本CUDA安装后无法运行。具体症状为:在编译时一切正常,在运行CUDA相关程序时报错:

CUDA driver version is insufficient for CUDA runtime version

在nvida 开发者论坛上有人已经解决,原文地址如下:
https://devtalk.nvidia.com/default/topic/1025945/cuda-setup-and-installation/mac-cuda-9-0-driver-fully-compatible-with-macos-high-sierra-10-13-error-quot-update-required-quot-solved-/

解决方案:

重新安装Nvidia 驱动的Web 版本代替MacOS原生版本。

下载地址为:
http://www.macvidcards.com/drivers.html

注意:自己的MacOS的版本,比如我现在版本为10.13.4,显示有2个可以选择:

  • 10.13.4 (17E199) 387.10.10.10.30.106
  • 10.13.4 (17E202) 387.10.10.10.30.107

在关于本机->系统报告->软件下可以看到具体版本的子版本号
系统软件概览:

  系统版本:	macOS 10.13.4 (17E199)
  内核版本:	Darwin 17.5.0
  启动宗卷:	Macintosh HD
  启动模式:	正常

所以我选择【10.13.4 (17E199) 387.10.10.10.30.106】

安装后需要重启电脑,然后在【设置】里面就可以看到Nvidia管理器,你可以在原生和新版之间自由切换。

新增一个问题

出现

Apple Clang is not supported 字样

要么Xcode版本太低,或者太高了,可以看每个版本的说明文档中对xcode的版本要求。
https://developer.download.nvidia.com/compute/cuda/9.2/Prod/docs/sidebar/CUDA_Installation_Guide_Mac.pdf
Google一下如何降级Xcode就可以编译了(升级比较简单)

注意

大多数笔记本显卡显存较低,许多计算框架提供的Demo都需要4G显存打底,可能在支持cuda后,一些软件反而运行不起来。

posted @ 2018-05-21 01:23  wang#  阅读(3988)  评论(0编辑  收藏  举报