[ZJU 1004] Anagrams by Stack

ZOJ Problem Set - 1004
Anagrams by Stack

Time Limit: 2 Seconds      Memory Limit: 65536 KB

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

Input

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]

and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.

Process

A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and
Pop - to retrieve the most recently pushed item

We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it's too short), neither is
i i o o o i (there's an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

Sample Input

madam
adamm
bahama
bahama
long
short
eric
rice

Sample Output

[
i i i i o o o i o o 
i i i i o o o o i o 
i i o i o i o i o o 
i i o i o i o o i o 
]
[
i o i i i o o i i o o o 
i o i i i o o o i o i o 
i o i o i o i i i o o o 
i o i o i o i o i o i o 
]
[
]
[
i i o i o i o o 
]

Source: Zhejiang University Local Contest 2001


 

Solution:

  暴力模拟

  每次先搜索push,再判断能否pop。

  回溯时需注意。

#include<bits/stdc++.h>
using namespace std;
char a[1005],b[1005];
int al;
int bl;
stack<char> T;
int opt[2010];
void DFS(int dep,int x,int y)
{
    //cout << dep << ' ' << x << ' ' << y << endl;
    if (x == al && y == bl)
    {
    //A successful opt.
    for (int i=1;i<=al+bl;i++)
    {
        if (opt[i] == 1)
        cout << "i ";
        else cout << "o ";
    }
    cout << endl;
    return;
    }
    if (x != al)
    {
    opt[dep]=1;
    T.push(a[x]);
    DFS(dep+1,x+1,y);
    T.pop();
    }
    if (!T.empty() && y != bl && T.top() == b[y])
    {
    char tmp = T.top();
        T.pop();
    opt[dep]=0;
    DFS(dep+1,x,y+1);
    T.push(tmp);
    }
    return;
}
void solve()
{
    al = strlen(a);
    bl = strlen(b);
    while (!T.empty()) T.pop();
    memset(opt,0,sizeof(opt));
    cout << '[' << endl;
    DFS(1,0,0);
    cout << ']' << endl;

}
int main()
{
    while (cin >> a >> b)
    solve();
}

 

 

posted @ 2018-09-26 15:52  dgklr  阅读(135)  评论(0编辑  收藏  举报