程序控

IPPP (Institute of Penniless Peasent-Programmer) Fellow

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: :: 管理 ::

ime Limit: 1 Second    Memory Limit: 32768 KB

 

Background

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

 

figure1

 

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

 

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

 

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

 

Sample input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

 

Sample output

5
1
5
2
4

 

Analysis

这道题数据量非常小,一共只有16个方格,因此用暴力搜索就可以了。在一个格子里放入Castle后要把它上下左右四个方向可以通达的所有格子进行标记,后面就不能再在这些格子里放入Castle了。

 

Solution

 

#include <iostream>
#include <vector>
using namespace std;

int nResult = 0;
void DoWork(int nOrder, char *pMat, int nBegin)
{
	vector<int> vecChanged;
	int nSquare = nOrder * nOrder, nCastleCnt = 0;
	for (; nBegin < nSquare; ++nBegin) {
		if (pMat[nBegin] == '.') {
			++nCastleCnt;
			pMat[nBegin] = 'O';
			vecChanged.clear();
			int nCol = nBegin % nOrder, nRow = nBegin / nOrder;
			for (int i = nRow - 1; pMat[i * nOrder + nCol] != 'X' &&
				i >= 0; --i) if (pMat[i * nOrder + nCol] == '.')
				vecChanged.push_back(i * nOrder + nCol);
			for (int i = nRow + 1; pMat[i * nOrder + nCol] != 'X' &&
				i < nOrder; ++i) if (pMat[i * nOrder + nCol] == '.')
				vecChanged.push_back(i * nOrder + nCol);
			for (int j = nCol - 1; pMat[nRow * nOrder + j] != 'X' &&
				j >= 0; --j) if (pMat[nRow * nOrder + j] == '.')
				vecChanged.push_back(nRow * nOrder + j);
			for (int j = nCol + 1; pMat[nRow * nOrder + j] != 'X' &&
				j < nOrder; ++j) if (pMat[nRow * nOrder + j] == '.')
				vecChanged.push_back(nRow * nOrder + j);
			for (vector<int>::iterator i = vecChanged.begin();
				i < vecChanged.end(); ++i) pMat[*i] = 'H';
				DoWork(nOrder, pMat, nBegin + 1);
			for (vector<int>::iterator i = vecChanged.begin();
				i != vecChanged.end(); ++i) pMat[*i] = '.';
				pMat[nBegin] = '.';
		}
	}
	if (0 == nCastleCnt) {
		int nCnt = 0;
		for (int i = 0; i < nSquare; ++i) nCnt += (pMat[i] == 'O');
		if (nCnt > nResult) nResult = nCnt;
	}
}

int main(void)
{
	vector<int> vecResult;
	for (; ;)
	{
		int nOrder;
		cin >> nOrder;
		if (0 == nOrder) break;
		int nSquare = nOrder * nOrder;
		char *pMat = new char[nSquare + 4];
		for (int i = 0; i < nOrder; ++i) cin >> (pMat + i * nOrder);
		nResult = 0;
		DoWork(nOrder, pMat, 0);
		vecResult.push_back(nResult);
		delete []pMat;
	}
	for (vector<int>::iterator i = vecResult.begin();
		i != vecResult.end(); ++i) cout << *i << endl;
		return 0;
}
posted on 2010-08-07 13:16  Devymex  阅读(1754)  评论(0编辑  收藏  举报