poj1159 Palindrome

Palindrome
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 44186   Accepted: 15050

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

输入a串,求其变成回文串所要进行的插入或删除操作的最少的步骤

Dp[i][j] 为a[i~j] 子串变为回文串所要进行插入或删除的操作的最少步骤。

            Min{dp[i][j-1]+1, dp[i-1][j]+1}       (a[i]!=a[j])

Dp[i][j]=

            Min{dp[i][j-1]+1,dp[i-1][j]+1,dp[i-1][j-1]}   (a[i]==a[j])

则最后答案为dp[1][n]


#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
short dp[5001][5001];
int n;
string s;
int main(){
    while(cin>>n>>s){
        memset(dp,0,sizeof(dp));
        for(int i=n-1;i>=0;i--){
             for(int j=i;j<n;j++){
                if(s[i]==s[j])dp[i][j]=dp[i+1][j-1];
                else
                dp[i][j]=min(dp[i+1][j],dp[i][j-1])+1;
             }
        }
             printf("%d\n",dp[0][n-1]);
    }
  return 0;
}
View Code

 

posted @ 2015-08-15 15:46  无解大神  阅读(176)  评论(0编辑  收藏  举报