Ace of Aces

Description

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

Sample Input

3
5
2 2 2 1 1
5
1 1 2 2 3
1
998

Sample Output

2
Nobody
998
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int a[1005];
int f[1005];

int main()
{
    int t,n,x,flag;
    int maxx;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(f,0,sizeof(f));
        maxx=-1;flag=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            f[a[i]]++;
        }
        for(int i=0;i<1004;i++)
        {
            if(f[a[i]]>maxx)
            {
                maxx=f[a[i]];
                x=a[i];
            }
        }
        for(int i=0;i<1004;i++)
            if(f[a[i]]==maxx&&a[i]!=x)
            flag++;
        if(flag>0)
            printf("Nobody\n");
        else
            printf("%d\n",x);
    }
    return 0;
}
View Code

 

posted @ 2015-07-17 21:12  无解大神  阅读(573)  评论(0编辑  收藏  举报