Beauty of Array

Description

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

 

#include <iostream>
using namespace std;
const int maxn=100005;
int n[maxn];

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        fill(n,n+maxn,0);
        int m;
        cin>>m;
        long long ans=0,dp=0;
        int t;
        for(int i=1;i<=m;i++)
        {
            cin>>t;
            dp=(i-n[t])*t+dp;
            ans+=dp;
            n[t]=i;
        }
        cout<<ans<<endl;
    }
    return 0;
}

  

 
posted @ 2015-07-17 21:09  无解大神  阅读(284)  评论(0编辑  收藏  举报