487-3279(map容器)

题目链接

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.
Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

题意

给你一些电话号码,但是给你的格式是不规则的,可能有 - 也可能有字母,如果是字母的话就按题意的规则映射成数字。最后输出相同的电话号码个数大于1的,并且输出它的个数。输出格式aaa-aaaa
输出顺序按照字典序,若没有相同个数大于一的电话号码就输出 No duplicates.

分析

如用map容器map<string,int>; 的话 到最后就要对字符串进行排序,这样就会超时。有与题意电话号码的位数是7位,把它转成int型是完全可以的。同时map容器还可以用迭代器来访问,这样就不用下标
从前到后遍历找个数大于一的了。用下标找的范围是(0~999999999)也会超时。

代码

#include<map>
#include<iostream>
#include<stdio.h>
using namespace std;
int zhuan(char a)
{
    int b;
    switch(a)
    {
    case '0':
        b= 0;
        break;
    case '1':
        b= 1;
        break;
    case 'A':
    case 'B':
    case 'C':
    case '2':
        b= 2;
        break;
    case 'D':
    case 'E':
    case 'F':
    case '3':
        b= 3;
        break;
    case 'G':
    case 'H':
    case 'I':
    case '4':
        b= 4;
        break;
    case 'J':
    case 'K':
    case 'L':
    case '5':
        b= 5;
        break;
    case 'M':
    case 'N':
    case 'O':
    case '6':
        b= 6;
        break;
    case 'P':
    case 'R':
    case 'S':
    case '7':
        b= 7;
        break;
    case 'T':
    case 'U':
    case 'V':
    case '8':
        b= 8;
        break;
    case 'W':
    case 'X':
    case 'Y':
    case '9':
        b= 9;
        break;
    default :
        break;
    }
    return b;
}
int main()
{
    int t;
    scanf("%d",&t);
    map<int,int>m;
    map<int,int>::iterator it;
    char a[100];
    while(t--)
    {
        scanf(" %s",a);
        int sum=0;
        for(int i=0; a[i]!='\0'; i++)
        {
            if(a[i]!='-')
            {
                sum=sum*10+zhuan(a[i]);
            }
        }
        m[sum]++;
    }
    int op=0;
    for(it=m.begin(); it!=m.end(); it++)
    {
        /// m[a]=b;
        if(it->second>1)///等价于  if(m[it]>1)  但是map容器 不能这样用
        {
            int a=it->first/10000;///  等价于  (*it)/10000;  但是也不能这样用
            int b=it->first%10000;
             printf("%03d-%04d  %d\n",a,b,it->second);
            op=1;
        }
    }
    if(op==0)
        printf("No duplicates.\n");
}
posted @ 2017-04-29 20:27  -梦里不知身是客  阅读(162)  评论(0编辑  收藏  举报