Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 166685    Accepted Submission(s): 41106

Problem Description

A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

分析

f(n) = (A * f(n - 1) + B * f(n - 2)) % 7.也就是

f(n) = A * f(n - 1) %7+ B * f(n - 2)%7.

A * f(n - 1) %7 取值范围是[0~6]

B * f(n - 2)%7 取值范围是[0~6]

所以f(n)的值最多有49 中可能,,所以最大周期是49

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<vector>
#include<string.h>
using namespace std;

int f[50];
int main()
{


 int a,b,c;
 while(scanf("%d%d%d",&a,&b,&c))
 {
     if(a==0&&b==0&&c==0)break;
     memset(f,0,sizeof(f));
     f[0]=1;
     f[1]=1;
     for(int i=2;i<=49;i++)
     {
         f[i]=(a*f[i-1]+b*f[i-2])%7;
         //printf("%d\n",f[i]);
     }
     printf("%d\n",f[(c-1)%49]);


 }

    return 0;
}

posted @ 2017-04-14 12:30  -梦里不知身是客  阅读(141)  评论(0编辑  收藏  举报