阿恒

导航

SVN与Eclipse的集成

j 写这篇文章真的有必要,真希望MyEclipse以后的版本能兼容SVN,这个插件装起来太麻烦了,抱怨到此结束,回归正题!
先看看官网对SVN插件的解释吧
Subversive distribution consists of two parts - Subversive plug-in and Subversive SVN Connectors. Both parts are required in order to work with Subversive. Subversive plug-in is provided under the terms and conditions of the Eclipse Public License Version 1.0 ("EPL"). A copy of the EPL is available at http://www.eclipse.org/legal/epl-v10.html. Subversive SVN Connectors are external libraries with their own licenses, which are distributed from external location at http://www.polarion.org/index.php?page=overview&project=subversive.   所有在地址http://www.eclipse.org/subversive/downloads.php 只能下载
Subversive plug-in这部分,另一部分下载等下说,先把 Subversive-incubation-0.7.8.I20090506-1500.zip 下载下来,解压到相应目录就好,重启后结果打开SVN 报错

SVN: '0x00400006: Validate Repository Location' operation finished with error: Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are available or install and select pure Java Subversion connector from the plug-in connectors update site.
If connectors already installed then you can change the selected one at: Window->Preferences->Team->SVN->SVN Client.
Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are available or install and select pure Java Subversion connector from the plug-in connectors update site.
If connectors already installed then you can change the selected one at: Window->Preferences->Team->SVN->SVN Client.
原来缺少一个SVN客户端,

posted on 2009-08-19 11:43  阿恒  阅读(10028)  评论(0编辑  收藏  举报