poj-1989 The Cow Lineup

The Cow Lineup
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5587 Accepted: 3311
Description

Farmer John’s N cows (1 <= N <= 100,000) are lined up in a row.Each cow is labeled with a number in the range 1…K (1 <= K <=10,000) identifying her breed. For example, a line of 14 cows might have these breeds:
1 5 3 2 5 1 3 4 4 2 5 1 2 3

Farmer John’s acute mathematical mind notices all sorts of properties of number sequences like that above. For instance, he notices that the sequence 3 4 1 3 is a subsequence (not necessarily contiguous) of the sequence of breed IDs above. FJ is curious what is the length of the shortest possible sequence he can construct out of numbers in the range 1..K that is NOT a subsequence of the breed IDs of his cows. Help him solve this problem.
Input

  • Line 1: Two integers, N and K

  • Lines 2..N+1: Each line contains a single integer that is the breed ID of a cow. Line 2 describes cow 1; line 3 describes cow 2; and so on.
    Output

  • Line 1: The length of the shortest sequence that is not a subsequence of the input
    Sample Input

14 5
1
5
3
2
5
1
3
4
4
2
5
1
2
3
Sample Output

3

脑洞题,做这种题目需要灵感。思路就是这个数列中包含1到k所有数字的子序列为一个集合,答案是就是集合数加1

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>

using namespace std;
#define MAX 100000
int a[MAX+5];
int b[MAX+5];
int n,k;
bool judge()
{
    for(int i=1;i<=k;i++)
        if(b[i]==0)
            return false;
    return true;
}
int main()
{
    int ans;
    int num;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        ans=0;
        num=0;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        memset(b,0,sizeof(b));
        for(int i=1;i<=n;i++)
        {
            if(!b[a[i]])
            {
                b[a[i]]=1;
                num++;
            }
            if(num==k)
            {
                ans++;
                num=0;
                memset(b,0,sizeof(b));
            }

        }
        printf("%d\n",ans+1);
    }
}
posted @ 2016-01-06 09:46  Shendu.CC  阅读(113)  评论(0编辑  收藏  举报