nyoj269VF(dp)



VF

时间限制:1000 ms  |  内存限制:65535 KB
难度:2
描述
Vasya is the beginning mathematician. He decided to make an important contribution to the science and to become famous all over the world. But how can he do that if the most interesting facts such as Pythagor’s theorem are already proved? Correct! He is to think out something his own, original. So he thought out the Theory of Vasya’s Functions. Vasya’s Functions (VF) are rather simple: the value of the Nth VF in the point S is an amount of integers from 1 to N that have the sum of digits S. You seem to be great programmers, so Vasya gave you a task to find the milliard VF value (i.e. the VF with N = 109) because Vasya himself won’t cope with the task. Can you solve the problem?
输入
There are multiple test cases.
Integer S (1 ≤ S ≤ 81).
输出
The milliard VF value in the point S.
样例输入
1
样例输出
10
//题意:1~1000000000之间,各位数字之和等于给定s的数的个数,每行给出一个数s(1 ≤ s ≤ 81),求出1~10^9内各位数之和与s相等的数的个数。
//所有情况都求出来。
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int dp[15][90];//dp[i][j]是前i位数的和为j的数有几个。
int k;
int main()
{
    memset(dp,0,sizeof(dp));
    for(int i=1; i<=9; i++)
    {
        dp[1][i]=1;
    }
    for(int i=2; i<=9; i++)
    {
        for(int j=1; j<=9*i; j++)
        {
            for(int l=0; l<=9&&l<=j; l++)
            {
                dp[i][j]+=dp[i-1][j-l];
            }
        }
    }
    while(~scanf("%d",&k))
    {
        int sum=0;
        if(k==1)
            printf("10\n");
        else
        {
            for(int i=1; i<=9; i++)
            {
                sum+=dp[i][k];
            }
            printf("%d\n",sum);
        }
    }
}

posted @ 2017-09-29 20:10  _大美  阅读(109)  评论(0编辑  收藏  举报