随笔 - 569  文章 - 3  评论 - 12617 

不知怎么的,我遇到的问题大伙都路过还是没经历过呢

本人机子装了VS2005+VS2010,所以framework是2.0;3.0;3.5;4.0都有了。

当我在新建Silverlight应用程序的时候,当然上面会有Framework版本选择,我默认的都选4.0版本的。

可是神奇的是,新建后的Silverlight版本引用的类库都是2.0版本的,引发的问题当然很严重了:

2.0的组件库里是没有NetTcpBinding,wsdualBinding等类的,这样还怎么玩呢?

想直接引用4.0的,当然提示无法引用了。

还是截图直观点:

1.新建4.0 framework版本的Silverlight应用程序:

2.我们随便看个引用的系统类库看下属性:

3.运行时和版本都成2.0的了,但是我们再看一下DLL的引用路径,在SL4.0下面的

我们进入到DLL的路径看真一下DLL:

太阳,原DLL还明明写着4.0版本的,看最后选中的那个。

4.如果要添加4.0的引用

5.结果就是这样了:

 

路过的大伙支支招,怎么修正这个新建时的运行库为4.0的。

posted on 2010-07-20 20:42 路过秋天 阅读(...) 评论(...) 编辑 收藏
路过秋天