【POJ 3694】 Network(割边<桥>+LCA)

【POJ 3694】 Network(割边+LCA)


Network
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 7971   Accepted: 2902

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ AB ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ ABN), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

Source


题目大意:n个点的无向图 初始化有m条边

之后q次操作 每次表示在点a与点b间搭建一条边 输出对于q次操作 每次剩下的桥的条数


初始化能够用tarjan算法求出桥 对于不是割边的两个点 就能够算是在一个集合中 这样用并查集就能够进行缩点

最后生成的就是一棵树 树边就是图中的全部桥 q次询问中 每次加边<u,v> 假设u和v在一个集合中 说明新的边不会造成影响

假设u和v在两个集合中 两个集合间的边在加入<u,v>后就会失去桥的性质 这样通过LCA就能够遍历全部两个集合间的集合 在加上<u,v>这条边后 这两个集合间的集合事实上就变成了一个环 也就是能够缩成一个点 在合并集合的过程中 就能够把消失的桥从总和中减去了


代码例如以下:

#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define Pr pair<int,int>
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout)

using namespace std;
const int INF = 0x3f3f3f3f;
const int msz = 10000;
const int mod = 1e9+7;
const double eps = 1e-8;

struct Edge
{
	int v,next;
};

Edge eg[666666];
int head[233333];
int dfn[233333],low[233333];
int pre[233333];
int fa[233333];
bool vis[233333];
int tp,tim;
int ans;

void init(int n)
{
	for(int i = 1; i <= n; ++i)
		pre[i] = i;
}

int Find(int x)
{
	return pre[x] == x? pre[x]: (pre[x] = Find(pre[x]));
}

int Union(int u,int v)
{
	int k = Find(u);
	int r = Find(v);
	if(k == r) return false;
	pre[k] = r;
	return true;
}

void Tarjan(int u,int p)
{
	vis[u] = 1;
	dfn[u] = low[u] = tim++;
	int v;

	for(int i = head[u]; i != -1; i = eg[i].next)
	{
		v = eg[i].v;
		if(v == p) continue;

		if(!vis[v])
		{
			fa[v] = u;
			Tarjan(v,u);
			low[u] = min(low[u],low[v]);
			if(low[v] > dfn[u])
			{
				ans++;
			}else Union(v,u);
		}
		else low[u] = min(low[u],dfn[v]);
	}

}

void lca(int u,int v)
{
	if(dfn[v] < dfn[u]) swap(u,v);

	while(dfn[v] > dfn[u])
	{
		if(Union(v,fa[v]))
			ans--;
		v = fa[v];
	}

	while(v != u)
	{
		if(Union(u,fa[u]))
			ans--;
		u = fa[u];
	}

}

int main()
{
	//fread();
	//fwrite();

	int n,m,u,v,z = 0;

	while(~scanf("%d%d",&n,&m) && (m+n))
	{
		memset(head,-1,sizeof(head));
		tim = tp = 0;
		init(n);

		while(m--)
		{
			scanf("%d%d",&u,&v);
			eg[tp].v = v;
			eg[tp].next = head[u];
			head[u] = tp++;

			eg[tp].v = u;
			eg[tp].next = head[v];
			head[v] = tp++;
		}

		memset(vis,0,sizeof(vis));
		ans = 0;
		fa[1] = 1;
		Tarjan(1,1);

		int q;
		scanf("%d",&q);

		printf("Case %d:\n",++z);

		while(q--)
		{
			scanf("%d%d",&u,&v);
			lca(u,v);
			printf("%d\n",ans);
		}
		puts("");
	}

	return 0;
}






posted @ 2017-08-20 16:34  cxchanpin  阅读(159)  评论(0编辑  收藏  举报