Drying

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input
sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5
Sample Output
sample output #1
3

sample output #2
2

题解:二分法。

设某次二分出的一个值是mid:
1、对于一件ai值小于等于mid的衣服,直接晾干即可;
2、对于一件ai值大于mid值的衣服,最少的用时是用机器一段时间,晾干一段时间,设这两段时间分别是x1和x2,那么有mid=x1+x2,ai<=k*x1+x2,解得x1>=(ai-mid)/(k-1) ,所以对(ai-mid)/(k-1)向上取整就是该件衣服的最少用时。


AC代码为:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;


long long n,k,a[100005];


bool f(long long x)
{
if(k==1)
{
return true;
}

long long time=0,i;
for(i=0;i<n;i++)
{
if(a[i]>x)
{
time+=(a[i]-x)/(k-1)+((a[i]-x)%(k-1)>0);
}
}
if(time>x)
return true;
return false;
}


int main()
{
long long max,i;

while(~scanf("%lld",&n))
{
max=0;

for(i=0;i<n;i++)
{
scanf("%lld",&a[i]);
if(a[i]>max)
max=a[i];
}

scanf("%lld",&k);

long long left=0,right=max,mid;

while(right-left>1)
{
mid=(left+right)/2;


if(f(mid))
{
left=mid;
}
else
right=mid;

}

printf("%lld\n",right);

}



return 0;
}//已经 



posted @ 2018-01-23 22:45  StarHai  阅读(372)  评论(0编辑  收藏  举报