Live2D

HDU - 1022 Train Problem I STL 压栈

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41471    Accepted Submission(s): 15510


Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
3 123 321 3 123 312
 

Sample Output
Yes. in in in out out out FINISH No. FINISH

通过火车进站前的顺序判断是否能改变为所给的顺序,火车需先进站然后再出站,可用STL中的stack实现,这里用数组模拟压栈

#include<stdio.h>
#include<string.h>
int main()
{
	int n;
	char s1[20]={0},s2[20]={0},s3[20];
	int s1_in[20],s2_in[20];
	while(~scanf("%d %s %s",&n,s1,s2))	
	{
		memset(s3,0,sizeof(s3));//需对数组进行清空
		
		int s[20]={0};
		int i1=0,i2=0,i3=0,i=0;
		//scanf("%s" "%s",s1,s2);
		for(i1=0;i1<n;i1++)//将字符转换为数字
		{
			s1_in[20]=s1[i]-'0';
			s2_in[20]=s2[i]-'0';
			
		}
		for(i1=0;i1<n;i1++)
		{
			s3[i3]=s1[i1];//火车进站
			i3++;
			i++;
			while(s3[i3-1]==s2[i2]&&i2<n)
			{
				i3--;
				s[i]=1;
				i2++;
				i++;
			}
		}
		//printf("%d %d %d %d\n",i1,i2,i3,i);
		if(i2==n)//火车全部出站
		{
			printf("Yes.\n");
			for(i1=0;i1<i;i1++)
			{
				if(s[i1]==1)
				{
					printf("out\n");
				}
				else
				printf("in\n");
			}
			printf("FINISH\n");
		}
		else
		{
			printf("No.\n");
			printf("FINISH\n");
		}
	}
	return 0;
} 



posted @ 2018-01-23 00:15  ITryagain  阅读(140)  评论(0编辑  收藏  举报