Live2D

POJ 2260 Error Correction 模拟 贪心 简单题

Error Correction
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6825   Accepted: 4289

Description

A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here's a 4 x 4 matrix which has the parity property:
1 0 1 0

0 0 0 0
1 1 1 1
0 1 0 1

The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2.
Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt.

Input

The input will contain one or more test cases. The first line of each test case contains one integer n (n<100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix. Input will be terminated by a value of 0 for n.

Output

For each matrix in the input file, print one line. If the matrix already has the parity property, print "OK". If the parity property can be established by changing one bit, print "Change bit (i,j)" where i is the row and j the column of the bit to be changed. Otherwise, print "Corrupt".

Sample Input

4
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 1 1 0
1 1 1 1
0 1 0 1
0

Sample Output

OK
Change bit (2,3)
Corrupt

计算每行每列1的数量,看奇数个的交叉点,大于一个或没有则不能实现。


#include<stdio.h>

int main()
{
	int a[105][105];
	int n;
	while (~scanf("%d", &n))
	{
		int i, j;
		int num1 = 0,num2=0;
		if (!n)
		{
			break;
		}
		int x, y;
		for ( i = 1; i <= n; i++)
		{
			int sum = 0;
			for ( j = 1; j <= n; j++)
			{
				scanf("%d", &a[i][j]);
				sum += a[i][j];
			}
			if (sum % 2 != 0)
			{
				x = i;
				num1++;
			}
		}
		for ( i = 1; i <= n; i++)
		{
			int sum = 0;
			for ( j = 1; j<= n;j++)
			{
				sum += a[j][i];
			}
			if (sum % 2 != 0)
			{
				y = i;
				num2++;
			}
		}
		
		if (num1 == 0 && num2 == 0)
		{
			printf("OK\n");
		}
		else if (num1 == 1 && num2 == 1)
		{
			printf("Change bit (%d,%d)\n", x, y);
		}
		else
		{
			printf("Corrupt\n");
		}
	}
	return 0;
}


posted @ 2018-01-24 23:06  ITryagain  阅读(192)  评论(0编辑  收藏  举报