Live2D

HDU - 3577 Fast Arrangement 线段树

Fast Arrangement

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3563    Accepted Submission(s): 1024


Problem Description
Chinese always have the railway tickets problem because of its' huge amount of passangers and stations. Now goverment need you to develop a new tickets query system.
One train can just take k passangers. And each passanger can just buy one ticket from station a to station b. Each train cannot take more passangers any time. The one who buy the ticket earlier which can be sold will always get the ticket.
 

Input
The input contains servel test cases. The first line is the case number. In each test case:
The first line contains just one number k( 1 ≤ k ≤ 1000 ) and Q( 1 ≤ Q ≤ 100000 )
The following lines, each line contains two integers a and b, ( 1 ≤ a < b ≤ 1000000 ), indicate a query.
Huge Input, scanf recommanded.
 

Output
For each test case, output three lines:
Output the case number in the first line.
If the ith query can be satisfied, output i. i starting from 1. output an blank-space after each number.
Output a blank line after each test case.
 

Sample Input
1 3 6 1 6 1 6 3 4 1 5 1 2 2 4
 

Sample Output
Case 1: 1 2 3 5
 

Author
Louty (Special Thanks Nick Gu)
 

Source
 

Recommend
zhouzeyong


题意:设计一个卖票系统,已经卖出的位置在乘车区间内不能再卖出,输出第几条输入的票可以卖出

思路:用线段树,每卖出一张票就修改指定区间的票数,最后检查总票数即可

#include<cstdio>
#include<cstring>
#define MAXN 1000010
struct node{
	int l, r,tag,num;
}tree[MAXN<<2];
int k,q, a, b,cas,len,cnt[MAXN];
int max(int a, int b)
{
	return a > b ? a : b;
}
void build(int k, int l, int r)
{
	tree[k].tag = 0; tree[k].num = 0;
	tree[k].l = l; tree[k].r = r;
	if (l == r)
		return;
	int mid = (l + r) >> 1;
	build(k << 1, l, mid);
	build(k << 1 | 1, mid + 1, r);
}
void pushup(int k)
{
	tree[k].num = max(tree[k << 1].num, tree[k << 1 | 1].num);
}
void pushdown(int k)
{
	tree[k << 1].num += tree[k].tag;
	tree[k << 1 | 1].num += tree[k].tag;
	tree[k << 1].tag += tree[k].tag;
	tree[k << 1 | 1].tag += tree[k].tag;
	tree[k].tag = 0;

}
void update(int k, int l, int r, int x)
{
	if (tree[k].l == l&&tree[k].r == r)
	{
		tree[k].num += x;
		tree[k].tag += x;
		return;
	}
	if (tree[k].tag)
		pushdown(k);
	int mid = (tree[k].l + tree[k].r) >> 1;
	if (r <= mid)
		update(k << 1, l, r, x);
	else if (l >= mid + 1)
		update(k << 1 | 1, l, r, x);
	else
	{
		update(k << 1, l, mid, x);
		update(k << 1 | 1, mid + 1, r, x);
	}
	pushup(k);
}
int query(int k, int l, int r)
{
	
	if (tree[k].l == l&&tree[k].r == r)
		return tree[k].num;
	if (tree[k].tag)
		pushdown(k);
	int mid = (tree[k].l + tree[k].r) >> 1;
	if (r <= mid)
		return query(k << 1, l, r);
	else if (l >= mid + 1)
		return query(k << 1 | 1, l, r);
	else
		return max(query(k << 1, l, mid) , query(k << 1 | 1, mid + 1, r));
}

int main()
{
	int t;
	cas = 1;
	scanf("%d", &t);
	while (t--)
	{
		memset(cnt, 0, sizeof(cnt));
		len = 1;
		scanf("%d%d", &k, &q);	
		build(1, 1, 1000010);
		for (int i = 1; i <= q; i++)
		{
			scanf("%d%d", &a, &b);
			b--;
			if (query(1, a, b) < k)
			{
				cnt[len++] = i;
				update(1, a, b, 1);
			}
		}
		printf("Case %d:\n", cas++);
		for (int i = 1; i < len; i++)
		{
			printf("%d ", cnt[i]);
		}
		printf("\n\n");

	}
	return 0;
}

posted @ 2018-05-22 19:18  ITryagain  阅读(113)  评论(0编辑  收藏  举报