Loading

串 --- 匹配

All in All
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 27295   Accepted: 11162

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

 

【题目来源】

Ulm Local 2002

 

【题目大意】

给定一个a串和一个b串,现在要你判断a串是否出现在b串中。

 

【题目分析】

直接模拟也能过,暴力出奇迹啊,

 

#include<string.h>
#include<stdio.h>
char a[100010],b[100010];
int main()
{
    while(scanf("%s%s",a,b)!=EOF)
    {
        int len1=strlen(a),len2=strlen(b);
        if(len1>len2)
        {
            printf("No\n");continue;
        }
        int cnt=0;
        for(int i=0;i<len2;i++)
        {
            if(a[cnt++]==b[i])
                cnt++;
        }
        if(cnt==len1)
            printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}

其实这种做法是投机取巧的,数据太弱的题目能过,但是遇到数据强的就wa了。

 

 

 

 

posted @ 2014-05-29 20:06  北岛知寒  阅读(195)  评论(0编辑  收藏  举报