不要过于沉溺过去,也不要过于畅想未来,把握现在!

D二分

<span style="color:#330099;">/*
D - 二分 基础
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
Description
Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input
The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39
Sample Output
2.00
By Grant Yuan
2014.7.15
二分*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[10005];
double b;
long long l,r,mid;
int n,size;
double add;
bool can(long long cc)
{    int sum=0;
    for(int i=0;i<n;i++)
        {
            sum=sum+a[i]/cc;
        }
    if(sum>=size)
       return true;
    return false;
}

int main()
{double max=0;long long add;
    while(~scanf("%d%d",&n,&size)){
      for(int i=0;i<n;i++)
        {
            scanf("%lf",&b);
             a[i]=(b+0.005)*100;
          if(b>max)
            max=b;
          add+=b;}
       if(add<size){
         cout<<"0.00"<<endl;
         continue;}
       l=0,r=(max+0.005)*100;
       while(r-l>0){
        mid=(l+r)*0.5+1;
        if(can(mid)){
             l=mid;
             }
         else{
             r=mid-1;}
         }
       printf("%.2lf\n",(double)r/100.0);}
       return 0;

}
</span>

posted @ 2014-07-15 17:55  coding_yuan  阅读(172)  评论(0编辑  收藏  举报

不要过于沉溺过去,也不要过于畅想未来,把握现在!