不要过于沉溺过去,也不要过于畅想未来,把握现在!

POJ 1125 Floyd

Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27978 Accepted: 15528

Description
Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input
Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output
For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source
Southern African 2001

在运用Floyd算法求解任意两点之间的最短路时,一点要把探位点放在最前面:

for(int k=1;k<=n;k++)
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)

cost[i][j]=min(cost[i][j],cost[i][k]+cost[k][j];

/*Source Code
Problem: 1125		User: X2012302616
Memory: 680K		Time: 0MS
Language: G++		Result: Accepted

    Source Code*/

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    int n;
    const int inf=0x3ffffff;
    int cost[107][107];
    int ans,ans_source;
    void floyd()
    {  
        for(int k=1;k<=n;k++)
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
        {
            if(i!=j&&cost[i][j]>cost[i][k]+cost[k][j]) cost[i][j]=cost[i][k]+cost[k][j];
        }
        ans=inf;int sum=0;
        for(int i=1;i<=n;i++)
        {
            sum=0;
            for(int j=1;j<=n;j++)
            {
                if(i!=j&&cost[i][j]>sum) sum=cost[i][j];
            }
            if(ans>sum){
                ans=sum;
                ans_source=i;
            }
        }
    }
    int main()
    {
       // freopen("in.txt","r",stdin);
        int m,a,b;
        while(1){
            scanf("%d",&n);
            if(n==0) break;
           //memset(cost,0,sizeof(cost));
            for(int i=0;i<=n;i++)
                 for(int j=0;j<=n;j++)
                 cost[i][j]=inf;
            for(int i=1;i<=n;i++)
            {
                //cost[i][i]=0;
                scanf("%d",&m);
                for(int j=1;j<=m;j++)
                {
                    scanf("%d%d",&a,&b);
                    cost[i][a]=b;
                }
            }
            floyd();
            if(ans<inf) printf("%d %d\n",ans_source,ans);
            else printf("disjoint\n");
        }
        return 0;
    }



 

posted @ 2015-01-26 09:43  coding_yuan  阅读(132)  评论(0编辑  收藏  举报

不要过于沉溺过去,也不要过于畅想未来,把握现在!