不要过于沉溺过去,也不要过于畅想未来,把握现在!

POJ 2240 Bellman_Ford

Arbitrage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16429 Accepted: 6909

Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Source

Ulm Local 1996

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<map>
#include<string>
using namespace std;
double cost[32][32];
double dis[32];
int n,m;
map<string,int>mapstring;
bool Bellman_Ford()
{
     for(int k=1;k<=n;k++)
        for(int i=1;i<=n;i++)
          for(int j=1;j<=n;j++)
     {
          if(cost[i][j]<cost[i][k]*cost[k][j]) cost[i][j]=cost[i][k]*cost[k][j];
     }
     for(int i=1;i<=n;i++)
        if(cost[i][i]>1) return true;
     return false;
}
int main()
{
   // freopen("in.txt","r",stdin);
    string s,s1,s2;
    double c;int cnt=1;
    while(1){
        scanf("%d",&n);
        if(n==0) break;
        for(int i=1;i<=n;i++)
        {
            cost[i][i]=1;
            cin>>s;
           mapstring[s]=i;
        }
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            cin>>s1>>c>>s2;
            cost[mapstring[s1]][mapstring[s2]]=c;
        }
        int ans=Bellman_Ford();
        if(ans) printf("Case %d: Yes\n",cnt++);
        else printf("Case %d: No\n",cnt++);
    }
    return 0;
}



 

posted @ 2015-01-26 16:11  coding_yuan  阅读(128)  评论(0编辑  收藏  举报

不要过于沉溺过去,也不要过于畅想未来,把握现在!