ubuntu下安装nginx时依赖库zlib,pcre,openssl安装方法

首先使用dpkg命令查看自己需要的软件是否安装。

例如查看zlib是否安装:

dpkg -l | grep zlib  

 


解决依赖包openssl安装,命令:

 
  1. sudo apt-get install openssl libssl-dev  

 

 

 

解决依赖包pcre安装,命令:

 

[cpp] view plain copy
 
  1. sudo apt-get install libpcre3 libpcre3-dev  

 

 

解决依赖包zlib安装,命令:

 

  1. sudo apt-get install zlib1g-dev 

 转自 http://blog.csdn.net/z920954494/article/details/52132125

posted @ 2017-07-06 09:24  chent  阅读(1176)  评论(0编辑  收藏  举报