HDU Problem 1513 Palindrome 【LCS】

 

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5182    Accepted Submission(s): 1770

Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 

 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

 

Sample Input
5 Ab3bd
 

 

Sample Output
2
 

 

Source
 

 

Recommend
linle   |   We have carefully selected several similar problems for you:  1505 1506 1074 1510 2602 
 
题意:问你最少插入多少个字符才可以使当前的字符串为回文字符串。
思路:如果这个字符串和他的逆串的LCS有公共的部分,说明公共部分的字符不需要再次替换了。而对于没在公共串上的元素,添加这些数量字串在相应的位置就可以。没有证明,但是想想就明白了。
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 5010;
int dp[2][MAXN], n;
char a[MAXN], b[MAXN];
int main() {
    while (scanf("%d", &n) != EOF) {
        scanf("%s", a);
        for (int i = 0; i < n; i++) {
            b[n - 1 - i] = a[i];
        }
        memset(dp, 0, sizeof(dp));
        for (int i = 1; i <= n; i++) {
            for (int j = 1; j <= n; j++) {
                if (a[i-1] == b[j-1]) dp[i%2][j] = dp[(i+1)%2][j-1] + 1;
                else dp[i%2][j] = max(dp[(i+1)%2][j], dp[i%2][j - 1]);
            }
        }
        printf("%d\n", n - dp[n%2][n]);
    }
    return 0;
}

 


 

 


 

posted @ 2016-08-12 19:51  zprhhs  阅读(123)  评论(0编辑  收藏  举报
Power by awescnb