题目链接

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award

me
aware
m
contest
hav
oo
or
i
fi
mre

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

分析:
哇,我的天。刚看见题目的时候确实被测试数据给吓到了,这都是什么鬼? 仔细读一下题目就会发现没有看着这么的可怕,完全靠着模拟来就行了。

首先给定一个单词字典,里面有一系列的单词,以“#”作为单词字典输入结束的标志。 然后会给定一个需要查询的单词,如果这个单词在上面给定的单词字典里面,就可以直接输出“该单词 is correct”,否的的话输出“该单词: 与该单词相似的单词”。

所谓的相似单词要求两个单词的长度差不能超过1
1:如果两个单词想等的话,要求这两个单词只能有一个对应位置的字符不一样;
2:两个单词的长度相差1,较长的单词可以在任意位置比较短的单词多出一个字符,如果去掉这个多出来的字符后,要求两个单词完全相同。

理解题意之后主要的就是看代码怎么写了,完全的是一个模拟的过程。

代码:

#include<stdio.h>
#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
#include<cmath>
using namespace std;
string str[10009];
string str1[10009];
bool alike(string str1,string str2)
{
    string temp;
    if(str1.length()>str2.length())//要求一定是str2的长度比较大,这样便于控制后面的字符串进行比较
    {
        temp=str1;
        str1=str2;
        str2=temp;
    }
    int cnt=0;
    if(str1.length()<str2.length())//考虑两个串长度不相等的情况,而且str1比较短
    {
        for(int i=0; i<str2.length()&&cnt<str1.length(); i++)//注意两个串下表的变化
            if(str2[i]==str1[cnt])
                cnt++;
        if(cnt==str1.length())//可以匹配,str1串中的任何一个字符都可以与str2串匹配上
            return true;
    }
    else//两串长度相等,但是保证只更改了其中的一个值
    {
        cnt=0;
        for(int i=0; i<str1.length(); i++)
            if(str2[i]==str1[i])
                cnt++;
        if(cnt==str1.length()-1)//相当于两个长度相同的单词里面,只有一个位置的字母是不一样的
            return true;
    }
    return false;
}

int main()
{
    int len_dic=0;
    string s;
    while(cin>>s)//输入单词字典
    {
        if(s=="#")  break;
        str[len_dic]=s;
        str1[len_dic]=s;
        len_dic++;
    }
    sort(str,str+len_dic);//将字典中的单词按照字典序排列,方便下面的查找是否存在时的二分算法,也只在这里用到了
    while(cin>>s)//输入要查找的单词
    {
        if(s=="#") break;
        int len=s.length();
        //能够在单词字典里面找到这个单词
        if(binary_search(str,str+len_dic,s)) //从a开始到a+size找和v相同的,//用二分查找(折半查找和v相同的)1、若存在,则输出* is correct
        {
            cout << s << " is correct\n" ;
            continue;
        }
        cout<<s<<": ";
        for(int i=0; i<len_dic; i++) //遍历整个单词字典,还是原来输进去的顺序,而不是按照字典序排列之后的
        {
            //与所需要查找的单词的位数差大于1的话,就肯定不是相似的单词
            if(str1[i].length()<len-1||str1[i].length()>len+1)
                continue;
            //与所需要查找的单词长度相等,或者位数只差一位,才有可能为相似的单词
            if(alike(str1[i],s))//
                cout<<str1[i]<<" ";
        }
        printf("\n");
    }
    return 0;
}
posted on 2018-04-08 21:08  渡……  阅读(334)  评论(0编辑  收藏  举报