题目链接

Problem Description
Consider the aggregate An= { 1, 2, …, n }. For example, A1={1}, A3={1,2,3}. A subset sequence is defined as a array of a non-empty subset. Sort all the subset sequece of An in lexicography order. Your task is to find the m-th one.

Input
The input contains several test cases. Each test case consists of two numbers n and m ( 0< n<= 20, 0< m<= the total number of the subset sequence of An ).

Output
For each test case, you should output the m-th subset sequence of An in one line.

Sample Input
1 1
2 1
2 2
2 3
2 4
3 10

Sample Output
1
1
1 2
2
2 1
2 3 1

分析:
给定1,2,3...N个数的集合,现在求所有非空子集(相同元素不同位置视为不同)按字典序排序后的第m个集合是什么?

我们用f[i]来表示i个元素的子序列的个数,可以找出地推的规律:f[n] = n * (f[n-1] + 1);
思路:求n个元素时序列首元素,序列变为n-1,
求n-1个元素时序列首元素......

用t = ceil(m/(f[n-1]+1)),即可求得所求序列在所有序列中是第几组,也就是当前第一个元素在序列数组a中的位置

用数组a表示序列数组[1,2,...,n](需要动态更新,每次求出t之后,都要删除t位置的元素)

在更新之后,序列数组总长度变为n-1,我们要求一下所求序列的新位置m = m - (t-1)*(f[n-1]+1) - 1(前面有t-1组,每组f[n-1]个元素)

代码:

#include<stdio.h>
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    int n;
    long long m, f[25];
    f[0] = 0;
    for (int i =1; i < 21; i++)
        f[i] = i * (f[i - 1] + 1);
    while (scanf("%d%lld", &n, &m) != EOF)
    {
        int flag = 1, a[25];
        for (int i = 1; i <= n; i++)
            a[i] = i;
        while (m > 0)
        {
            int t = ceil(m * 1.0 / (f[n - 1] + 1));//求出的是n个数字的首元素的位置
            if (!flag)
                printf(" ");
            flag = 0;
            printf("%d", a[t]);
            for (int i = t; i < n; i++)//然后要删去这个元素
                a[i] = a[i + 1];
            m = m - (t - 1) * (f[n - 1] + 1) - 1;//去掉一个元素后,总共的个数也要改变
            n--;
        }
        printf("\n");
    }
    return 0;
}
posted on 2017-11-12 17:48  渡……  阅读(453)  评论(0编辑  收藏  举报