题目链接

Problem Description

Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked

leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then

on,people have sovled many problems by the the theory of the Universal Gravitation. What's more, wo also

have known every object has its Center of Gravity.

Now,you have been given the coordinates of three points of a triangle. Can you calculate the center

of gravity of the triangle?

Input

The first line is an integer n,which is the number of test cases.

Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.

The input is terminated by n = 0.

Output

For each case, print the coordinate, accurate up to 1 decimal places.

Sample Input

2
1.0 2.0 3.0 4.0 5.0 2.0
1.0 1.0 4.0 1.0 1.0 5.0
0

Sample Output

3.0 2.7
2.0 2.3

分析:

三角形的三个点的坐标,求出这个三角形的重心。

X=(x0+x1+x2)/3;

Y=(y0+y1+y2)/3;

代码:

#include<stdio.h>
#include<iostream>
using namespace std;
int main()
{
    double x[3];
    double y[3];
    int n;
    while(~scanf("%d",&n),n)
    {
        while(n--)
        {
            scanf("%lf%lf%lf%lf%lf%lf",&x[0],&y[0],&x[1],&y[1],&x[2],&y[2]);
            printf("%.1lf %.1lf\n",(x[0]+x[1]+x[2])/3,(y[0]+y[1]+y[2])/3);
        }
    }
    return 0;
}
posted on 2017-05-03 17:41  渡……  阅读(228)  评论(0编辑  收藏  举报