EHDU-1039 asier Done Than Said?

Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember. 

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules: 

It must contain at least one vowel. 

It cannot contain three consecutive vowels or three consecutive consonants. 

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'. 

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable. 

InputThe input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters. 
OutputFor each password, output whether or not it is acceptable, using the precise format shown in the example. 
Sample Input

a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end

Sample Output

<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.




思路:
合格的字符串需要满足三个条件。
(1)至少一个元音;
(2)不能有3个连续的元音或辅音;
(3)不能有连续相同的字母,除非是 ‘e' 或 'o';
#include<bits/stdc++.h>
using namespace std;
#define N 1000001
char s[N]; 
int main()
{
    while(scanf("%s",s),strcmp(s,"end")){  //end 结束
  	int len=strlen(s),a=0,b=0;    // a 表示连续的元音, b 表示连续的辅音
  	int x = 0,y = 0;               //y 表示是否出现过元音,x 表示是否有不符合条件2、3的情况
  	for(int i=0;i<len;i++){
	  if(s[i]=='a' || s[i]=='e' || s[i]=='i' || s[i]=='o' ||s[i]=='u'){
	  	y = 1;
	  	a++;
	  	b=0;
	  }
	  else{
		b++,a=0;
	  } 
  	  if(a==3 || b==3){
  	  	x = 1;
  	  	break;
  	  }
  	  if(i!=0 && s[i]!='e'&&s[i]!='o' && s[i]==s[i-1]){
  	  	x = 1;
  	  	break;
  	  }
  	}
  	if(x || !y){
  		printf("<%s> is not acceptable.\n",s);
  	}
	else{
		printf("<%s> is acceptable.\n",s);
	}
  }
  return 0;
} 

  

posted @ 2019-02-16 14:04  陈墨cacm  阅读(164)  评论(0编辑  收藏  举报