在Windows2008r2 安装.net4.5

WebApi 是比较高的环境下面开发 需要的环境是net4.5 或以上。

Windows2008r2 里面没有这个环境必须自己安装。安装net4.5 必须sp1环境以上才能安装。

  1. Windows2008r2  系统升级到 sp1 系统。

下载 sp1 升级包   

 https://www.microsoft.com/zh-cn/download/details.aspx?id=584

下载上面的程序进行安装,安装后重新启动服务器即可。

 

  1. 下载.n4.5升级包。 https://www.microsoft.com/zh-CN/download/confirmation.aspx?id=42642

 

进行安装。

 

  2. 部署webApi 后进行运行会报一个错误。

 

    HTTP 错误 500.21 - Internal Server Error 处理程序

  原因:在安装Framework v4.0之后,再启用IIS,导致Framework没有完全安装
解决方案:在开始里面的搜索程序里输入CMD找到命令管理器,然后输入以下这样一串字符即可:
%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i

 

 

2

posted @ 2019-04-01 11:06  游林  阅读(12600)  评论(1编辑  收藏  举报