MySQL安装解决办法
安装后没有服务
1.用管理员身份打开命令控制台(cmd),将mysql的安装文件的路径打开(bin文件的路径)
命令行命令:直接f: ,可直接进入f盘;cd 下一级目录名,可进入到下一级目录
(我的mysql安装文件路径在f:\program files\mysql\mysql server 5.5,所有命令为f:、cd program files、cd mysql...)
2.在路径下打上mysqld.exe -install,会出现提示 Service successfully installed.
3.输入如下命令C:\Program Files\MySQL\MySQL Server 5.6\bin>net start mysql
服务正在启动
服务启动成功,则成功。
服务启动失败
若服务启动失败,提示“服务正在启动或停止中 请稍候”
则输入命令“tasklist| findstr "mysql"”,用于查找mysql的残留进程,此时要做的就是杀死MySQL进程。
之后输入命令“taskkill /f /t /im mysqld.exe”,就可以将mysql残留进程全部杀死了,再次输入命令“tasklist| findstr "mysql"”,查看是否还留有有其他的mysql残留进程,如果还有,则继续杀死,直到完全杀死进程为止,如下图所示。

ZIP压缩包安装后没有my.ini配置文件
解决思路:先删除MySql服务,在mysql文件夹中新建一个my.ini文件,最后使用命令行重新初始化mysql服务,同时指定新建的my.ini作为服务默认的配置文件。
1.删除MySql服务
运行命令:sc delete MySql(其中“MySql”是服务名称),如果没有成功,尝试杀死进程。
2.新建my.ini配置文件
新建后记事本打开,复制黏贴内容,注意basedir和datadir根据时间mysql安装位置进行修改。
3.重新生成data文件
运行命令:mysqld --initialize-insecure --user=mysql
4.重新安装mysql服务,同时绑定my.ini配置文件
运行命令:mysqld --install "MySql55" --defaults-file="f:/program files/mysql/mysql server 5.5/my.ini"
其中“MySql55”是服务名称
浙公网安备 33010602011771号