杭电ACM-1.2.6 Decimal System

decimal system

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2640 Accepted Submission(s): 1026
 

Problem Description

As we know , we always use the decimal system in our common life, even using the computer. If we want to calculate the value that 3 plus 9, we just import 3 and 9.after calculation of computer, we will get the result of 12.
But after learning <<The Principle Of Computer>>,we know that the computer will do the calculation as the following steps:
1 computer change the 3 into binary formality like 11;
2 computer change the 9 into binary formality like 1001;
3 computer plus the two number and get the result 1100;
4 computer change the result into decimal formality like 12;
5 computer export the result;

In the computer system there are other formalities to deal with the number such as hexadecimal. Now I will give several number with a kind of change method, for example, if I give you 1011(2), it means 1011 is a number in the binary system, and 123(10) means 123 if a number in the decimal system. Now I will give you some numbers with any kind of system, you guys should tell me the sum of the number in the decimal system.

 

Input

There will be several cases. The first line of each case contains one integers N, and N means there will be N numbers to import, then there will be N numbers at the next N lines, each line contains a number with such form : X1….Xn.(Y), and 0<=Xi<Y, 1<Y<=10. I promise you that the sum will not exceed the 100000000, and there will be at most 100 cases and the 0<N<=1000.

 

Output

There is only one line output case for each input case, which is the sum of all the number. The sum must be expressed using the decimal system.

 

Sample Input

3

1(2)

2(3)

3(4)

 

4

11(10)

11(2)

11(3)

11(4)

 

Sample Output

6

23

 

 

代码:

#include<iostream>
#include<iomanip>
#include<string>
#include<cstdlib>
using namespace std;

int cf(int n1,int n2)
{
     int sum=1;
     while(n2--)
          sum*=n1;
     return sum;
}


int convert(int num1,int num2)
{
     int sum=0,i=0;
     while(num1)
     {
          if((num1%10)<num2)
          {
               sum+=(num1%10)*cf(num2,i);
               i++;
               num1/=10;
          }
     }
     return sum;
}


int main()
{
     int N,n,sum;
     string c,c1,c2;
     while(cin>>N&&N<=1000)
     {
          sum=0;
          do
          {
               getline(cin,c);
               c1=c.substr(0,c.find('('));
               c2=c.substr(c.find('(')+1,c.find(')')-c.find('(')-1);
               int b1=atoi(c1.c_str());
               int b2=atoi(c2.c_str());
              
               sum+=convert(b1,b2);              
          }while(N--);
          if(sum<=10000000)
               cout<<sum<<endl;    
     }    
    
     return 0;
}

 

posted @ 2013-06-12 20:00  cityflickr  阅读(331)  评论(0编辑  收藏  举报