7-17 求逆序对数目

注意:本问题算法的时间复杂度要求为O(nlogn), 否则得分无效

题目来源:http://poj.org/problem?id=1804 Background Raymond Babbitt drives his brother Charlie mad. Recently Raymond counted 246 toothpicks spilled all over the floor in an instant just by glancing at them. And he can even count Poker cards. Charlie would love to be able to do cool things like that, too. He wants to beat his brother in a similar task.

Problem Here's what Charlie thinks of. Imagine you get a sequence of N numbers. The goal is to move the numbers around so that at the end the sequence is ordered. The only operation allowed is to swap two adjacent numbers. Let us try an example: Start with: 2 8 0 3 swap (2 8) 8 2 0 3 swap (2 0) 8 0 2 3 swap (2 3) 8 0 3 2 swap (8 0) 0 8 3 2 swap (8 3) 0 3 8 2 swap (8 2) 0 3 2 8 swap (3 2) 0 2 3 8 swap (3 8) 0 2 8 3 swap (8 3) 0 2 3 8

So the sequence (2 8 0 3) can be sorted with nine swaps of adjacent numbers. However, it is even possible to sort it with three such swaps: Start with: 2 8 0 3 swap (8 0) 2 0 8 3 swap (2 0) 0 2 8 3 swap (8 3) 0 2 3 8

The question is: What is the minimum number of swaps of adjacent numbers to sort a given sequence?Since Charlie does not have Raymond's mental capabilities, he decides to cheat. Here is where you come into play. He asks you to write a computer program for him that answers the question in O(nlogn). Rest assured he will pay a very good prize for it.

输入格式:

The first line contains the length N (1 <= N <= 1000) of the sequence; The second line contains the N elements of the sequence (each element is an integer in [-1000000, 1000000]). All numbers in this line are separated by single blanks.

输出格式:

Print a single line containing the minimal number of swaps of adjacent numbers that are necessary to sort the given sequence.

输入样例:

在这里给出一组输入。例如:

6
-42 23 6 28 -100 65537

输出样例:

在这里给出相应的输出。例如:

5
code【C++】

#include <iostream>
using namespace std;
int merge (int A[], int left, int mid, int right) {
static int count = 0;
int result[right - left + 1];
int i = left;
int j = mid + 1;
int k = 0;
while (i <= mid && j <= right) {
if (A[i] <= A[j]) {
result[k ++] = A[i ++];
}
else
{
count += mid - i + 1;
result[k ++] = A[j ++];
}
}
while (j <= right)
result [k ++] = A[j ++];
while (i <= mid)
result[k ++] = A[i ++];
for (k = 0; k < right - left + 1;k ++)
A[left + k] = result[k];
return count;
}
int mergeSort(int a[], int left, int right) {
int sum = 0;
if (left < right) {
int mid = (left + right)/2;
mergeSort (a, left, mid);
mergeSort (a, mid + 1, right);
sum = merge (a, left, mid, right);
}
return sum;

}
int main(int argc, char** argv)
{
int n;
cin>>n;
int a[n];
for(int i = 0; i < n; i++){
int m;
cin>>m;
a[i] = m;

}
int left = 0, right = n - 1;
cout<<mergeSort(a, left, right);
return 0;

}

感想:

如图,太困难了。

 

posted on 2018-10-07 19:21  Z..Z  阅读(1232)  评论(0编辑  收藏  举报

导航