你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误
你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误
Posted on 2006-02-28 16:04 oo复oo 阅读(1372) 评论(20) 编辑 收藏 收藏至365Key
答案 当然是 肯定的。但不作任何处理的默认情况下,会出问题!
各位在同一电脑上同时安装并运行.net 1.1 和 .net 2.0 两个版本的朋友要小心啊!
您的项目是不是时不时会出现 Server Application Unavailable 错误呢?或者一直连续都出这个错误!
今天我朋友将其从1.1升级至2.0的项目发布至公司安装有windows 2003的服务器上,结果2.0的项目始终无法成功运行。甚至还造成服务器上正在为全公司服务的基于.net Framework 1.1的web程序出错。他感觉很奇怪,在自己电脑上明明运行的很好啊,怎么一到服务器上就不行了?
他发布2.0 web程序的过程如下:
1、在服务器上创建一个目录,然后将发布后的所有Web程序的文件复制到这个新建的目录。
2、在服务器的IIS上新建一个虚拟目录,然后 将其配置成可以执行脚本的应用程序,(过程与创建.net Framework 1.1版本的程序相同。) 然后,将此虚拟目录的.net Framework 配置成2.0。
大功告成后,开始访问刚配置的程序,却得到如下错误:
Server Application Unavailable
The web application you are attempting to access on this web server is currently unavailable. Please hit the "Refresh" button in your web browser to retry your request.
Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.
之后向我求助,经过仔细阅读了IIS帮助文档,才发现,原来这个错误是由 IIS6 应用程序隔离机制造成的。IIS默认的应用程序隔离机制被称为:“工作进程隔离模式”,在此模式中,应用程序被分为多个组,每个组就是一个“应用程序池” ,每个应用程序池之间是相互隔离的。 隔离的好处当然就是安全啦,稳定啦,等等。IIS中的每个应用程序池由一个“工作进程”分别进行管理,也就是"W3wp.exe" 。如果有多个应用程序池中的程序运行,我们就能看到多个w3wp.exe。 我们平时新建的虚拟目录都默认被指向IIS6的“DefaultAppPool" 中, 所以在默认情况下,不管你有多少个asp.net程序在运行,在“Windows任务管理器”中你只能看到一个w3wp.exe进程。
出现上述错误的原因是: .net Framework 2.0的程序与.net Framework1.1(或1.0)的程序被放入同一个应用程序池(默认情况下放入DefaultAppPool池),也就是由同一个工作进程: w3wp.exe 进行管理,而单个工作进程是无法同时管理不同的程序(或者不同版本的程序)的。如果先访问.net framework 1.1的页面,则工作进程先加载并管理了 1.1版本的程序集,此时访问.net framework 2.0的web程序页面,Server Application Unavailable 错误就出来了。 反之,如果在默认应用程序池的w3wp.exe尚未启动前先访问了 2.0的web程序(此时应用程序集已经加载了.net framework2.0的Web程序集),再访问1.1或1.0的Web程序页面时,同样会出现“服务器应用程序不可用” 这样的中文提示。(您可以结束掉以前的w3wp.exe进行测试。)
我朋友之所以在自己的开发机器上没出现此错误是因为他在开发基于.net framework 2.0的项目时,一直都只访问这个2.0的web程序,跟本未曾访问过其他web程序。而朋友的服务器上已经存在1.0 的项目,并且一直有人使用。这个错误在今天之前从未碰到过,其实大部分人在开发一个项目时,都只访问正在开发的项目。很有可能就忽略了这个问题,而到了发布的时候却出现错误,搞得手忙脚乱。
解决办法: 在IIS中新建一个应用程序池,然后选中你的 基于.net framework2.0的虚拟目录,点“属性”-》在“应用程序池” 中选择刚才新建的的应用程序池,点击“确定”。
如果你的电脑主要是为了学习,开发,测试web程序,完全可以建一个类似于名为"dotnet2.0"的应用程序池,以后所有新建的2.0的虚拟目录都指向此应用程序池。
[2006-03-16 更新] : 如果通地vs 2005IDE 直接创建在IIS 上创建Web Site时,vs 2005会自动添加 ASP.NET 2.0 应用程序池,并且将新创建的Web Size 虚拟目录指向新建的应用程序池。
Feedback
楼主好象结论下的过于早了,即使这样将来也会有问题出现的。呵呵~~微软的产品。
这也不能说微软的东东有啥问题。 作一些配置是必要的。至于将来的问题,我们都是凡人。
不谢! 我也是今天才发现这个问题
在自己电脑上重启IIS也无所谓,只要能正常使用,但如果发布至服务器上就麻烦了。 如果你的服务器只运行2.0的web程序,那就无所谓了,不配置也可以。
啊呀呀!
偶每次都是aspnet.regiis -r !搞的还有些担心生怕哪天又出状况!
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-02-28 19:43 by dudu
谢谢作者分享这个经验, 这是个容易被忽略的问题。
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-01 09:02 by [天道酬勤]
我得机器装完2005自动创建了一个ASP.NET V2.0的应用程序池。
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-01 09:02 by [天道酬勤]
我得机器装完2005自动创建了一个ASP.NET V2.0的应用程序池。
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-01 09:51 by 知道得越多知道的越少
这个经验很有价值,我们不久就可能遇到.谢谢分享.
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-01 15:06 by spgoal
如果在本地调试,不用IIS都可以呀,VS.NET2005自带一个本地服务器
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-01 15:38 by Boler Guo
@spgoal
就是本地调试没问题,发布之后才有问题的~
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-01 17:21 by bbpnb
可算找到组织了,前些天服务器上发布了两个应用程序,一个是DNN3.2,基于framework 1.1的,另一个是基于framework2.0的web程序,结果就出现“Server Application Unavailable ”问题,调了好久,百思不得其解,今天才发现问题在这!多谢!
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-02 10:36 by oo复oo
在本地开发调试的时候当然没问题了,你用的是自带的一个 信息服务程序, 但一般人都会在发布程序后, 先在IIS上建一个把文件复制过去 测试一下。
其实问题的关键是你自己的开发时,只关注正在开发的系统,很少会去访问其他版本的系统。出现问题的机率很少。 但当你布署到服务器上就不一样了。 一般服务器都不可能只放一套系统,很可能会存在 其他版本的程序。 这样下来,问题就来了。而由于你一直没发现这个错误,跟本没准备,而且这个问题产生的原因很容易被忽视,在布署后,就显得非常被动。
微软的东东过于强调人性化,希望帮我们做好一切。 所以他的IIS 默认就帮我们选好了线程池,而且大部分情况下,我们不用去调整他。所以导致我们跟本不会注意的线程池的影响,甚至用了n久的IIS还不知道这个线程池是干啥用的。
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-03 00:24 by 家中慢步
多谢楼主分享经验!
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-03 14:13 by 教师
农村教师苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!苦也!
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-03 14:44 by Cassaba
谢谢,我也遇到了这个问题,刚开始时时根本不能同时建立.net 2.0. .net 1.1的虚拟目录,后来独立发布成两个站点,似乎好了。今天出现了楼主说的问题了。
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-03 16:00 by Boler Guo
前天看到这篇文章,今天就遇到问题,正好用这个方案解决了~~
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-03 16:04 by Cassaba
补充一下如何建立Application Pool
How to Create Application Pools
Important This feature of IIS 6.0 is available only when running in worker process isolation mode.
With IIS 6.0 running in worker process isolation mode, you can group Web applications into application pools. Application pools allow specific configuration settings to be applied to groups of applications, and the worker processes servicing those applications. Any Web directory or virtual directory can be assigned to an application pool.
By creating new application pools and assigning Web sites and applications to them, you can make your server more efficient and reliable, and your other applications always available, even when the applications in the new application pool terminate.
Important You must be a member of the Administrators group on the local computer to perform the following procedure (or procedures), or you must have been delegated the appropriate authority. As a security best practice, log on to your computer using an account that is not in the Administrators group, and then use the Run as command to run IIS Manager as an administrator. From the command prompt, type runas /user:administrative_accountname "mmc %systemroot%\system32\inetsrv\iis.msc".
To create a new application pool
In IIS Manager, expand the local computer, right-click Application Pools, point to New, and then click Application Pool.
In the Application pool ID box, type the name of the new application pool.
Under Application pool settings, click either Use default settings for new application pool or Use existing application pool as template.
If you selected Use existing application pool as template, from the Application pool name list box, click the application pool to be used as a template.
Click OK.
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-03 17:46 by abcdefg111
日志内容: 传入参数:BindVnetAccountConfirm,值:3Aey6642guuRlu/5utb08bqdNM3Hf7A2Lpf5j+HuuzBSYN5z3RQOpZYVrCP6cTmSIG2VHh8LxB8DVymMdzb9cLuwuGHcfHGDmdw0JOvGnXNLUuSGDyaOhfE9jseTYwqsD1fTIhsO/qMkO1AFvypCs0vzZI2HNMYoppIBPqR7TRCo7gyrhZxdNGzmfygDNMTM30rkFxFd4c7BNujoK3DKSCIPOjgyGsRpTqpaeFjpl2yS08r9nS4vHEpOUPPp4Dds1VljWOXg7fDfNFwu/O4CJcQu46qB1t4k7TqNzfOAqbs= 调用对象:BindVnetAccount接口确认错误编号:-19999 错误描述:用户已经与SP用户帐号捆绑(捆绑代收费用)
你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误
Posted on 2006-02-28 16:04 oo复oo 阅读(1372) 评论(20) 编辑 收藏 收藏至365Key各位在同一电脑上同时安装并运行.net 1.1 和 .net 2.0 两个版本的朋友要小心啊!
您的项目是不是时不时会出现 Server Application Unavailable 错误呢?或者一直连续都出这个错误!
今天我朋友将其从1.1升级至2.0的项目发布至公司安装有windows 2003的服务器上,结果2.0的项目始终无法成功运行。甚至还造成服务器上正在为全公司服务的基于.net Framework 1.1的web程序出错。他感觉很奇怪,在自己电脑上明明运行的很好啊,怎么一到服务器上就不行了?
他发布2.0 web程序的过程如下:
1、在服务器上创建一个目录,然后将发布后的所有Web程序的文件复制到这个新建的目录。
2、在服务器的IIS上新建一个虚拟目录,然后 将其配置成可以执行脚本的应用程序,(过程与创建.net Framework 1.1版本的程序相同。) 然后,将此虚拟目录的.net Framework 配置成2.0。
大功告成后,开始访问刚配置的程序,却得到如下错误:
Server Application Unavailable
The web application you are attempting to access on this web server is currently unavailable. Please hit the "Refresh" button in your web browser to retry your request.
Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.
之后向我求助,经过仔细阅读了IIS帮助文档,才发现,原来这个错误是由 IIS6 应用程序隔离机制造成的。IIS默认的应用程序隔离机制被称为:“工作进程隔离模式”,在此模式中,应用程序被分为多个组,每个组就是一个“应用程序池” ,每个应用程序池之间是相互隔离的。 隔离的好处当然就是安全啦,稳定啦,等等。IIS中的每个应用程序池由一个“工作进程”分别进行管理,也就是"W3wp.exe" 。如果有多个应用程序池中的程序运行,我们就能看到多个w3wp.exe。 我们平时新建的虚拟目录都默认被指向IIS6的“DefaultAppPool" 中, 所以在默认情况下,不管你有多少个asp.net程序在运行,在“Windows任务管理器”中你只能看到一个w3wp.exe进程。
出现上述错误的原因是: .net Framework 2.0的程序与.net Framework1.1(或1.0)的程序被放入同一个应用程序池(默认情况下放入DefaultAppPool池),也就是由同一个工作进程: w3wp.exe 进行管理,而单个工作进程是无法同时管理不同的程序(或者不同版本的程序)的。如果先访问.net framework 1.1的页面,则工作进程先加载并管理了 1.1版本的程序集,此时访问.net framework 2.0的web程序页面,Server Application Unavailable 错误就出来了。 反之,如果在默认应用程序池的w3wp.exe尚未启动前先访问了 2.0的web程序(此时应用程序集已经加载了.net framework2.0的Web程序集),再访问1.1或1.0的Web程序页面时,同样会出现“服务器应用程序不可用” 这样的中文提示。(您可以结束掉以前的w3wp.exe进行测试。)
我朋友之所以在自己的开发机器上没出现此错误是因为他在开发基于.net framework 2.0的项目时,一直都只访问这个2.0的web程序,跟本未曾访问过其他web程序。而朋友的服务器上已经存在1.0 的项目,并且一直有人使用。这个错误在今天之前从未碰到过,其实大部分人在开发一个项目时,都只访问正在开发的项目。很有可能就忽略了这个问题,而到了发布的时候却出现错误,搞得手忙脚乱。
解决办法: 在IIS中新建一个应用程序池,然后选中你的 基于.net framework2.0的虚拟目录,点“属性”-》在“应用程序池” 中选择刚才新建的的应用程序池,点击“确定”。
如果你的电脑主要是为了学习,开发,测试web程序,完全可以建一个类似于名为"dotnet2.0"的应用程序池,以后所有新建的2.0的虚拟目录都指向此应用程序池。
[2006-03-16 更新] : 如果通地vs 2005IDE 直接创建在IIS 上创建Web Site时,vs 2005会自动添加 ASP.NET 2.0 应用程序池,并且将新创建的Web Size 虚拟目录指向新建的应用程序池。
在自己电脑上重启IIS也无所谓,只要能正常使用,但如果发布至服务器上就麻烦了。 如果你的服务器只运行2.0的web程序,那就无所谓了,不配置也可以。
偶每次都是aspnet.regiis -r !搞的还有些担心生怕哪天又出状况!
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-02-28 19:43 by dudu# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-01 09:02 by [天道酬勤]# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-01 09:02 by [天道酬勤]# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-01 09:51 by 知道得越多知道的越少# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-01 15:06 by spgoal# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-01 15:38 by Boler Guo就是本地调试没问题,发布之后才有问题的~
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-01 17:21 by bbpnb# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-02 10:36 by oo复oo其实问题的关键是你自己的开发时,只关注正在开发的系统,很少会去访问其他版本的系统。出现问题的机率很少。 但当你布署到服务器上就不一样了。 一般服务器都不可能只放一套系统,很可能会存在 其他版本的程序。 这样下来,问题就来了。而由于你一直没发现这个错误,跟本没准备,而且这个问题产生的原因很容易被忽视,在布署后,就显得非常被动。
微软的东东过于强调人性化,希望帮我们做好一切。 所以他的IIS 默认就帮我们选好了线程池,而且大部分情况下,我们不用去调整他。所以导致我们跟本不会注意的线程池的影响,甚至用了n久的IIS还不知道这个线程池是干啥用的。
# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-03 00:24 by 家中慢步# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-03 14:13 by 教师# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-03 14:44 by Cassaba# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-03 16:00 by Boler Guo# re: 你的.net 2.0 真的能与1.1 安全正确地运行在同一台电脑上吗? 小心Server Application Unavailable 错误 回复
2006-03-03 16:04 by CassabaHow to Create Application Pools
Important This feature of IIS 6.0 is available only when running in worker process isolation mode.
With IIS 6.0 running in worker process isolation mode, you can group Web applications into application pools. Application pools allow specific configuration settings to be applied to groups of applications, and the worker processes servicing those applications. Any Web directory or virtual directory can be assigned to an application pool.
By creating new application pools and assigning Web sites and applications to them, you can make your server more efficient and reliable, and your other applications always available, even when the applications in the new application pool terminate.
Important You must be a member of the Administrators group on the local computer to perform the following procedure (or procedures), or you must have been delegated the appropriate authority. As a security best practice, log on to your computer using an account that is not in the Administrators group, and then use the Run as command to run IIS Manager as an administrator. From the command prompt, type runas /user:administrative_accountname "mmc %systemroot%\system32\inetsrv\iis.msc".
To create a new application pool
In IIS Manager, expand the local computer, right-click Application Pools, point to New, and then click Application Pool.
In the Application pool ID box, type the name of the new application pool.
Under Application pool settings, click either Use default settings for new application pool or Use existing application pool as template.
If you selected Use existing application pool as template, from the Application pool name list box, click the application pool to be used as a template.
Click OK.

浙公网安备 33010602011771号