HDU-5384

Danganronpa

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 210    Accepted Submission(s): 116


Problem Description
Danganronpa is a video game franchise created and developed by Spike Chunsoft, the series' name is compounded from the Japanese words for "bullet" (dangan) and "refutation" (ronpa).

Now, Stilwell is playing this game. There are n verbal evidences, and Stilwell has m "bullets". Stilwell will use these bullets to shoot every verbal evidence.

Verbal evidences will be described as some strings Ai, and bullets are some strings Bj. The damage to verbal evidence Ai from the bullet Bj is f(Ai,Bj).
f(A,B)=i=1|A||B|+1[ A[i...i+|B|1]=B ]
In other words, f(A,B) is equal to the times that string B appears as a substring in string A.
For example: f(ababa,ab)=2f(ccccc,cc)=4

Stilwell wants to calculate the total damage of each verbal evidence Ai after shooting all m bullets Bj, in other words is mj=1f(Ai,Bj).
 

 

Input
The first line of the input contains a single number T, the number of test cases.
For each test case, the first line contains two integers nm.
Next n lines, each line contains a string Ai, describing a verbal evidence.
Next m lines, each line contains a string Bj, describing a bullet.

T10
For each test case, n,m1051|Ai|,|Bj|104|Ai|105|Bj|105
For all test case, |Ai|6105|Bj|6105Ai and Bj consist of only lowercase English letters
 

 

Output
For each test case, output n lines, each line contains a integer describing the total damage of Ai from all m bullets, mj=1f(Ai,Bj).
 

 

Sample Input

1
5 6
orz
sto
kirigiri
danganronpa
ooooo
o
kyouko
dangan
ronpa
ooooo
ooooo

 

 

Sample Output

1
1
0
3
7

 

 

Source
/**
    裸AC自动机  kuangbin模版
**/
#include<iostream>
#include<string.h>
#include<algorithm>
#include<stdio.h>
#include<cmath>
#include<queue>
#define maxn 500010
using namespace std;
struct Tire
{
    int next[maxn][26], fail[maxn], end[maxn];
    int root, L;
    int newnode() {
        for(int i = 0; i < 26; i++) {
            next[L][i] = -1;
        }
        end[L++] = 0;
        return L - 1;
    }
    void init() {
        L = 0;
        root = newnode();
    }
    void insert(char s[]) {
        int len = strlen(s);
        int now = root;
        for(int i = 0; i < len; i++) {
            if(next[now][s[i] - 'a'] == -1) {
                next[now][s[i] - 'a'] = newnode();
            }
            now = next[now][s[i] - 'a'];
        }
        end[now] ++;
    }
    void build() {
        queue<int>Q;
        fail[root] = root;
        for(int i = 0; i < 26; i++)
            if(next[root][i] == -1) {
                next[root][i] = root;
            }
            else {
                fail[next[root][i]] = root;
                Q.push(next[root][i]);
            }
        while(!Q.empty()) {
            int now = Q.front();
            Q.pop();
            for(int i = 0; i < 26; i++)
                if(next[now][i] == -1) {
                    next[now][i] = next[fail[now]][i];
                }
                else {
                    fail[next[now][i]] = next[fail[now]][i];
                    Q.push(next[now][i]);
                }
        }
    }
    int query(char buf[]) {
        int len = strlen(buf);
        int now = root;
        int res = 0;
        for(int i = 0; i < len; i++) {
            now = next[now][buf[i] - 'a'];
            int temp = now;
            while(temp != root) {
                res += end[temp];
                temp = fail[temp];
            }
        }
        return res;
    }
};
char buf[10010][10010];
char buf1[100100];
Tire ac;
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int n, m;
        scanf("%d %d", &n, &m);
        for(int i = 0; i < n; i++)
        {
            scanf("%s", buf[i]);
        }
        ac.init();
        for(int i = 0; i < m; i++)
        {
            scanf("%s", buf1);
            ac.insert(buf1);
        }
        ac.build();
        for(int i = 0; i < n; i++)
        {
            printf("%d\n", ac.query(buf[i]));
        }
    }
    return 0;
}

 

posted on 2015-08-13 20:56  `Elaine  阅读(157)  评论(0编辑  收藏  举报

导航