HDU-4185

Oil Skimming

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1155    Accepted Submission(s): 485


Problem Description
Thanks to a certain "green" resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water's surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.
 

 

Input
The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of '#' represents an oily cell, and a character of '.' represents a pure water cell.
 

 

Output
For each case, one line should be produced, formatted exactly as follows: "Case X: M" where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.
 

 

Sample Input
1 6
......
.##...
.##...
....#.
....##
......
 
Sample Output
Case 1: 3
 

 

Source
 

 

Recommend
lcy
/**
          题意:给出一个矩阵,然后求矩阵中有多少个‘##’(上下左右)都行
          做法:二分图最大匹配,匈牙利算法,时间复杂度是O(VE),
**/
#include<iostream>
#include<cmath>
#include<string.h>
#include<algorithm>
#include<stdio.h>
#define maxn 670
using namespace std;
char ch[maxn][maxn];
int mmap[maxn][maxn];
int g[maxn][maxn];
int linker[maxn];
int used[maxn];
int num = 0;
int n;
int  dfs(int u)
{
          for(int v = 0;v<num;v++)
          {
                    if(g[u][v] && used[v] == 0)
                    {
                              used[v] = 1;
                              if(linker[v] == -1 || dfs(linker[v]))
                              {
                                        linker[v] = u;
                                        return 1;
                              }
                    }
          }
          return 0;
}
int hungary()
{
          memset(linker,-1,sizeof(linker));
          int res = 0;
          for(int i=0;i<num;i++)
          {
                    memset(used,0,sizeof(used));
                    if(dfs(i)) res++;
          }
          return res;
}
int main()
{
//#ifndef ONLINE_JUDGE
        // freopen("in.txt","r",stdin);
//#endif // ONLINE_JUDGE
          int T;
          scanf("%d",&T);
          int Case = 1;
          while(T--)
          {
                    scanf("%d",&n);
                    num = 0;
                    for(int i=0;i<n;i++)
                    {
                              scanf("%s",ch[i]);
                    }
                    for(int i=0;i<n;i++)
                    {
                              for(int j=0;j<n;j++)
                              {
                                        if(ch[i][j] == '#') mmap[i][j] = num++;
                              }
                    }
                    memset(g,0,sizeof(g));
                    for(int i=0;i<n;i++)
                    {
                              for(int j=0;j<n;j++)
                              {
                                        if(ch[i][j] == '#')
                                        {
                                                  if(i<n-1 && ch[i+1][j] == '#')
                                                  {
                                                            g[mmap[i][j]][mmap[i+1][j]] = 1;
                                                            g[mmap[i+1][j]][mmap[i][j]] = 1;
                                                  }
                                                  if(j<n-1 && ch[i][j+1] == '#')
                                                  {
                                                            g[mmap[i][j]][mmap[i][j+1]] = 1;
                                                            g[mmap[i][j+1]][mmap[i][j]] = 1;
                                                  }
                                        }
                              }
                    }
                   int re = hungary();
                    printf("Case %d: %d\n",Case++,re/2);
          }
          return 0;
}

 

posted on 2015-04-04 19:43  `Elaine  阅读(175)  评论(0编辑  收藏  举报

导航