UVA - 315

 

      

B - Network

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0.

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2
/**
          题意:给出一个图,让判断割点有几个
          做法:Tarjan 计算割点
**/
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<cmath>
#include<algorithm>
using namespace std;
#define maxn 110
#define maxm 100010
struct Edge
{
    int to;
    int next;
    bool cut;
} edge[maxm];
int head[maxn],tot;
int Low[maxn],DFN[maxn],Stack[maxn];
int Index,top;
bool Instack[maxn];
bool cut[maxn];
int add_block[maxn];
int bridge;
void addedge(int u,int v)
{
    edge[tot].to = v;
    edge[tot].next = head[u];
    edge[tot].cut = false;
    head[u] = tot++;
}
void Tarjan(int u,int pre)
{
    int v;
    Low[u] = DFN[u] = ++Index;
    Stack[top++] = u;
    Instack[u] = true;
    int son = 0;
    for(int i=head[u]; i != -1; i = edge[i].next)
    {
        v = edge[i].to;
        if(v == pre) continue;
        if(!DFN[v])
        {
            son++;
            Tarjan(v,u);
            if(Low[u] > Low[v]) Low[u] = Low[v];
            ///求桥
            if(Low[v]>DFN[u])
            {
                bridge++;
                edge[i].cut = true;
                edge[i^1].cut = true;
            }
            ///求割点
            if(u!=pre && Low[v] >= DFN[u])
            {
                cut[u] = true;
                add_block[u] ++;
            }
        }
        else if(Low[u] > DFN[v])
        {
            Low[u] = DFN[v];
        }
    }
    if(u == pre && son>1) cut[u] = true;
    if(u == pre)add_block[u] = son -1;
    Instack[u] = false;
    top--;
}
void solve(int N)
{
    memset(DFN,0,sizeof(DFN));
    memset(Instack,false,sizeof(Instack));
    memset(add_block,0,sizeof(add_block));
    memset(cut,false,sizeof(cut));
    Index = top = 0;
    bridge = 0;
    for(int i=1; i<=N; i++)
    {
        if(!DFN[i]) Tarjan(i,i);
    }
    int ans = 0;
    for(int i=1; i<=N; i++)
    {
        if(cut[i]) ans++;
    }
    printf("%d\n",ans);
}
int g[maxn][maxn];
int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
    int n;
    while(~scanf("%d",&n))
    {
        if(n == 0) break;
        int u,v;
        memset(g,0,sizeof(g));
        while(scanf("%d",&u))
        {
            if(u == 0) break;
            while(getchar()!='\n')
            {
                scanf("%d",&v);
                g[u][v] = g[v][u] = 1;
            }
        }
        memset(head,-1,sizeof(head));
        tot = 0;
        for(int i=1; i<=n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                if(g[i][j])
                {
                    addedge(i,j);
                    addedge(j,i);
                }
            }
        }
        solve(n);
    }
    return 0;
}

 

posted on 2015-03-26 09:13  `Elaine  阅读(138)  评论(0编辑  收藏  举报

导航