hdu 1325 Is It A Tree?

Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 

 

 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 
 

 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 
 

 

Sample Input
6 8 5 3 5 2 6 4 5 6 0 0
8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0
3 8 6 8 6 4 5 3 5 6 5 2 0 0
-1 -1
 

 

Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
好诡异的一道题啊,一开始没注意有向,写错了,还以为是什么原因,后来直接dfs遍历树了,还是没有处理好,唉!写代码的能力有待提高
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
    int num,pre,root;
}tree[100005];

int find(int x)
{
    return x==tree[x].root?x:tree[x].root=find(tree[x].root);
}

void init()
{
    for (int i=0;i<=100001;i++)
    {
        tree[i].num=0;
        tree[i].pre=0;
        tree[i].root=i;
    }
}

int main()
{
    int x,y,k;
    k=0;
    bool flag=true;
    init();
    while (scanf("%d%d",&x,&y)!=EOF && x!=-1 && y!=-1)
    {
        if (!flag && x!=0 && y!=0) continue;
        if (x==0 && y==0)
        {
            k++;
            int root_num=0;
            for (int i=1;i<=100001;i++)
            {
                if (tree[i].num && tree[i].root==i) root_num++;
                if (root_num>1){flag=false;break;}
                if (tree[i].pre>1) {flag=false;break;}
            }
            if (flag) printf("Case %d is a tree.\n",k);
            else printf("Case %d is not a tree.\n",k);
            flag=true;
            init();
            continue;
        }
        if (x!=y && find(x)==find(y)) flag=false;
        else
        {
            tree[x].num=1;
            tree[y].num=1;
            tree[y].pre++;
            if (tree[y].pre>1) flag=false;
            x=find(x);
            y=find(y);
            if(x!=y) tree[y].root=x;
        }
    }
    return 0;
}

 

 

 

posted @ 2014-05-09 21:07  Hust_BaoJia  阅读(154)  评论(0编辑  收藏  举报
努力