2015 HUAS Summer Trainning #4~C

         My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

         My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

         What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:

• One line with two integers N and F with 1 ≤ N, F ≤ 10000: the number of pies and the number of friends.

• One line with N integers ri with 1 ≤ ri ≤ 10000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V . The answer should be given as a oating point number with an absolute error of at most 10−3 .

Sample Input

3

3 3

4 3 3

1 24

5

10 5

1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327

3.1416

50.2655

解题思路:这个题目最好用二分法求解,但是注意的事是它的输出是带有小数点的,所以设置数组时应该设置成double类型的,还有PI的设置不是简单的设置成#define PI 3.14,这样也会出现错误,还有输出的时候带有四个小数,在输出格式时应改变一下形式,在这里我就犯过错误。在输入时应注意输入的人数在题目中的意思是输入的是朋友的人数,但是题目中还写了作者自己也要一份一样大的蛋糕,所以在输入人数时要记得加加一下,不然案例通不过。

程序代码:

#include"stdio.h"
#include"math.h"
#define PI acos(-1.0)
double max(double p,double q)
{
	return p>q?p:q;
}
int main()
{
	int T,n,i,p,v;
	double low,mid,cnt;
	double a[10005];
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&p);
		p++;
		cnt=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&v);
			a[i]=PI*v*v;
			cnt=max(cnt,a[i]);
		}
		low=0;
		mid=(low+cnt)/2;
		while(cnt-low>=0.0000001)
		{
			v=0;
			for(i=0;i<n;i++)
				v+=(int)(a[i]/mid);
			if(v>=p)
				low=mid;
			else
				cnt=mid;
			mid=(low+cnt)/2;
		}
		printf("%0.4lf\n",mid);
	}
	return 0;
}
posted @ 2015-08-06 10:00  简约。  阅读(126)  评论(0编辑  收藏  举报