【Vue2.x】Vue UI中无法安装指定版本依赖解决方法

问题:Vue UI中无法安装指定版本依赖

方法:

  • vue ui中添加依赖如图所示,无法选择某个版本的依赖,可通过在vue项目中的package.json和package-lock.json文件中添加指定版本的版本号以及依赖的下载地址等信息。

  • 比如,需要安装less和less-loader某个版本,可在package.json文件中添加:

  • 在package-lock.json文件中分别添加:


    (less-loader的图未截完,太多了..)

  • 最后在vscode项目终端中输入“npm install”即可。

ps:此方法限制颇多,你得找到指定版本依赖的相关信息,然后才能正确添加到package-lock.json中。

posted @ 2021-10-05 18:44  Chen_HW  阅读(588)  评论(0编辑  收藏  举报