UVA11400 Lighting System Design

Description

You are given the task to design a lighting system for a huge conference hall. After doing a lot of calculation & sketching, you have figured out the requirements for an energy-efficient design that can properly illuminate the entire hall. According to your design, you need lamps of n different power ratings. For some strange current regulation method, all the lamps need to be fed with the same amount of current. So, each category of lamp has a corresponding voltage rating. Now, you know the number of lamps & cost of every single unit of lamp for each category. But the problem is, you are to buy equivalent voltage sources for all the lamp categories. You can buy a single voltage source for each category (Each source is capable of supplying to infinite number of lamps of its voltage rating.) & complete the design. But the accounts section of your company soon figures out that they might be able to reduce the total system cost by eliminating some of the voltage sources & replacing the lamps of that category with higher rating lamps. Certainly you can never replace a lamp by a lower rating lamp as some portion of the hall might not be illuminated then. You are more concerned about money-saving than energy-saving. Find the minimum possible cost to design the system.

Input Instruction

Each case in the input begins with n (1<=n<=1000), denoting the number of categories. Each of the following n lines describes a category. A category is described by 4 integers - V (1<=V<=132000), the voltage rating, K (1<=K<=1000), the cost of a voltage source of this rating, C (1<=C<=10), the cost of a lamp of this rating & L (1<=L<=100), the number of lamps required in this category. The input terminates with a test case where n = 0. This case should not be processed.

Output Instruction

For each test case, print the minimum possible cost to design the system.

Sample Input

3

100 500 10 20

120 600 8 16

220 400 7 18

0

Sample Output

778

Analysis

必须消除局部最优,考虑灯泡变换分为几个点,定义dp[i]为1-i-1灯泡中若干灯泡用ai替换,那么还有前面的一些替换灯泡
下证若灯泡j被i替换,j-i-1均被i替换
∵灯泡j被i替换

∴(l[i]-l[j])*c[j]-k[j]<0

又∵灯泡j不能被j+1替换

∴(l[j+1]-l[j])c[j]-k[j]>(l[i]-l[j])c[j]-k[j]

∴l[j+1]< l[i]

∴(l[i]-l[j+1])*c[j+1]-k[j+1]<0

∴灯泡j+1能被i替换
可得出递推公式dp[i]=min{dp[j]+(s[i]-s[j])*c[i]+k[i]}

Code

#include<bits/stdc++.h>
using namespace std;
struct Node{
    int v,k,c,l;
}node[1001];
int dp[1005],s[1001];
inline bool cmp(Node a,Node b){return a.v<b.v;}
int main(){
    int n,i,j,x;
	while(~scanf("%d",&n),n){
		dp[0]=s[0]=0;
        for(i=1;i<=n;++i)
            scanf("%d%d%d%d",&node[i].v,&node[i].k,&node[i].c,&node[i].l);
        sort(node+1,node+n+1,cmp);
        for(i=1;i<=n;++i){
            s[i]=s[i-1]+node[i].l;dp[i]=10000000;
            for(j=0;j<i;++j)
            dp[i]=min(dp[i],dp[j]+(s[i]-s[j])*node[i].c +node[i].k);
        }
        printf("%d\n",dp[n]);
    }
    return 0;
}
posted @ 2019-12-30 19:49  飞翔的菜鸟123  阅读(132)  评论(0编辑  收藏  举报