链接:http://acm.hdu.edu.cn/showproblem.php?pid=1102

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13305    Accepted Submission(s): 5038


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

 

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
 

 

Sample Output
179
 
 
 
 
基本就是经典的最小生成树问题,题目中加了一个条件,有已经修建过的道路,不用重新建造
 
处理办法就是把已经建造的地方在图中权值附为0,注意无向图,要把对称的地方都赋值为0
再用最小生成树的方法走一遍,即可
 
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>

#define MaxInt 0x7fffffff
int map[105][105],low[105],visit[105];
int n;

int prim()
{
    int i,j;
    int result = 0,minn,pos=1;
    memset(visit,0,sizeof(visit));
    visit[pos]=1;
    for(i=1;i<=n;i++)
    {
        if(i != pos)
        {
            low[i]=map[pos][i];
        }
    }

    for(i=1;i<n;i++)
    {
        minn=MaxInt;
        for(j=1;j<=n;j++)
        {
            if(visit[j]==0&&minn>low[j])
            {
                minn=low[j];
                pos=j;
            }
        }
        visit[pos]=1;
        result+=minn;
        for(j=1;j<=n;j++)
        {
            if(visit[j]==0&&low[j]>map[pos][j])
            {
                low[j]=map[pos][j];
            }
        }
    }
    return result;
}
int main()
{
    int i,j,m,k,a,b;
    while(scanf("%d",&n)!=EOF)
    {
        //memset(visit,MaxInt,sizeof(visit));这样初始化有问题
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&map[i][j]);
            }
        }
        scanf("%d",&m);
        for(k=1;k<=m;k++)
        {
            scanf("%d%d",&a,&b);
            map[a][b]=map[b][a]=0;
        }
        int result=prim();
        printf("%d\n",result);
    }
    return 0;
}