KMP模板题,做了一天,泪奔啊~~~

 

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 

 

Sample Output
6
-1

 

#include <stdio.h>
#include <string.h>

int s[1000005];
int p[10005],next[100005];
int n,m;
void getNext(int p[],int next[])
{
    int k,j;
    k=-1;
    j=0;
    next[0]=-1;
    while(j<m-1)
    {
        if(k==-1||p[k]==p[j])
        {
            j++;
            k++;
            next[j]=k;
        }
        else k=next[k];
    }
}

int KMPMatch(int s[],int p[])
{
    int i,j;
    i=0;j=0;
    getNext(p,next);
    while(i<n&&j<m)
    {
        if(j==-1||s[i]==p[j])
        {
               i++;
               j++;
        }
        else j=next[j];

    }
        if(j>=m)return i-m+1;
        else return -1;
}

int  main()
{
    int i,j,k;
    scanf("%d",&k);
    while(k--)
    {
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++)scanf("%d",&s[i]);
        for(i=0;i<m;i++)scanf("%d",&p[i]);
        printf("%d\n",KMPMatch(s,p));
    }
    return 0;
}