POJ 3624 Charm Bracelet (01背包)

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 23950   Accepted: 10802

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23
大致题意:贝西有一堆首饰,每个首饰有它的魅力值和重量。现在第一行输入n个首饰和最大重量为m。接下来n行每行两个数a和b,a为首饰的魅力值,b为该首饰的魅力值。求贝西能在不超过最大重量的情况下,最大魅力值是多少?
#include <iostream>
using namespace std;
int f[12900];
int w[3410],v[3410];
int main(void)
{
	int n,m,i;
	cin >> n >> m;
	for(i=1; i<=n; i++)
		cin >> w[i] >> v[i];
	memset(f,0,sizeof(f));
	for(i=1; i<=n; i++)
		for(int j=m; j>=w[i]; j--)
			if( f[j-w[i]]+ v[i] > f[j] )
				f[j] = f[j-w[i]]+ v[i];
	cout << f[m] << endl;
return 0;
}
 

posted on 2014-10-12 20:34  TopCoder  阅读(113)  评论(0编辑  收藏  举报

导航