Centos 7.5 通过yum安装GNOME Desktop时出现:file /boot/efi/EFI/centos from install of fwupdate-efi-12-5.el7.centos.x86_64 conflicts with file from package grub2-common-1:2.02-0.65.el7.centos.2.noarch

系统版本为:

[root@s10 ~]# cat /etc/redhat-release 
CentOS Linux release 7.5.1804 (Core)

由于管理kvm虚拟机的需求,需要安装GNOME Desktop 和Graphical Administration Tools 桌面服务。

通过

[root@s10 ~]# yum groupinstall "GNOME Desktop" "Graphical Administration Tools" -y

时出现如下错误提示:

(829/853): xorg-x11-drv-synaptics-1.9.0-2.el7.x86_64.rpm                                                                                                              |  82 kB  00:00:00     
(830/853): xorg-x11-drv-qxl-0.1.5-4.el7.1.x86_64.rpm                                                                                                                  |  92 kB  00:00:00     
(831/853): xorg-x11-drv-vmmouse-13.1.0-1.el7.1.x86_64.rpm                                                                                                             |  24 kB  00:00:00     
(832/853): xorg-x11-drv-vesa-2.4.0-1.el7.x86_64.rpm                                                                                                                   |  25 kB  00:00:00     
(833/853): xorg-x11-drv-wacom-0.36.1-1.el7.x86_64.rpm                                                                                                                 | 315 kB  00:00:00     
(834/853): xorg-x11-drv-void-1.4.1-2.el7.1.x86_64.rpm                                                                                                                 |  14 kB  00:00:00     
(835/853): xorg-x11-fonts-Type1-7.5-9.el7.noarch.rpm                                                                                                                  | 521 kB  00:00:00     
(836/853): xorg-x11-font-utils-7.5-21.el7.x86_64.rpm                                                                                                                  | 104 kB  00:00:00     
(837/853): xorg-x11-proto-devel-2018.4-1.el7.noarch.rpm                                                                                                               | 280 kB  00:00:00     
(838/853): xorg-x11-drv-ati-18.1.0-1.el7_6.x86_64.rpm                                                                                                                 | 164 kB  00:00:01     
(839/853): xorg-x11-utils-7.5-23.el7.x86_64.rpm                                                                                                                       | 114 kB  00:00:00     
(840/853): xvattr-1.3-27.el7.x86_64.rpm                                                                                                                               |  22 kB  00:00:00     
(841/853): yelp-3.28.1-1.el7.x86_64.rpm                                                                                                                               | 777 kB  00:00:00     
(842/853): xorg-x11-xkb-utils-7.7-14.el7.x86_64.rpm                                                                                                                   | 103 kB  00:00:00     
(843/853): yelp-libs-3.28.1-1.el7.x86_64.rpm                                                                                                                          | 101 kB  00:00:00     
(844/853): yum-langpacks-0.4.2-7.el7.noarch.rpm                                                                                                                       |  31 kB  00:00:00     
(845/853): xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64.rpm                                                                                                           | 1.4 MB  00:00:01     
(846/853): xorg-x11-drv-vmware-13.2.1-1.el7.1.x86_64.rpm                                                                                                              |  83 kB  00:00:02     
(847/853): cgdcbxd-1.0.2-7.el7.x86_64.rpm                                                                                                                             |  25 kB  00:00:00     
(848/853): xorg-x11-server-common-1.20.1-5.3.el7_6.x86_64.rpm                                                                                                         |  54 kB  00:00:01     
(849/853): colord-1.3.4-1.el7.x86_64.rpm                                                                                                                              | 477 kB  00:00:00     
(850/853): zenity-3.28.1-1.el7.x86_64.rpm                                                                                                                             | 4.0 MB  00:00:02     
(851/853): control-center-filesystem-3.28.1-4.el7.x86_64.rpm                                                                                                          |  25 kB  00:00:01     
(852/853): yelp-xsl-3.28.0-1.el7.noarch.rpm                                                                                                                           | 204 kB  00:00:03     
(853/853): libblockdev-utils-2.18-3.el7.x86_64.rpm                                                                                                                    |  58 kB  00:00:01     
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
总计                                                                                                                                                         1.9 MB/s | 777 MB  00:06:45     
Running transaction check
Running transaction test


Transaction check error:
  file /boot/efi/EFI/centos from install of fwupdate-efi-12-5.el7.centos.x86_64 conflicts with file from package grub2-common-1:2.02-0.65.el7.centos.2.noarch

错误概要
-------------

该问题是由于文件fwupdate-efi 同grub2-common冲突所致,这里需要将该包通过yum update grub2-common命令进行更新。

[root@s10 ~]# yum update grub2-common
已加载插件:fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.aliyun.com
 * epel: mirrors.aliyun.com
 * extras: mirrors.163.com
 * updates: mirrors.cn99.com
正在解决依赖关系
--> 正在检查事务
---> 软件包 grub2-common.noarch.1.2.02-0.65.el7.centos.2 将被 升级
--> 正在处理依赖关系 grub2-common = 1:2.02-0.65.el7.centos.2,它被软件包 1:grub2-tools-minimal-2.02-0.65.el7.centos.2.x86_64 需要
--> 正在处理依赖关系 grub2-common = 1:2.02-0.65.el7.centos.2,它被软件包 1:grub2-pc-modules-2.02-0.65.el7.centos.2.noarch 需要
--> 正在处理依赖关系 grub2-common = 1:2.02-0.65.el7.centos.2,它被软件包 1:grub2-tools-2.02-0.65.el7.centos.2.x86_64 需要
--> 正在处理依赖关系 grub2-common = 1:2.02-0.65.el7.centos.2,它被软件包 1:grub2-tools-extra-2.02-0.65.el7.centos.2.x86_64 需要
--> 正在处理依赖关系 grub2-common = 1:2.02-0.65.el7.centos.2,它被软件包 1:grub2-pc-2.02-0.65.el7.centos.2.x86_64 需要
---> 软件包 grub2-common.noarch.1.2.02-0.76.el7.centos.1 将被 更新
--> 正在检查事务  

更新升级完毕。。 继续执行命令:

[root@s10 ~]# yum groupinstall "GNOME Desktop" "Graphical Administration Tools" -y
更新完毕:
  selinux-policy.noarch 0:3.13.1-229.el7_6.9                                                                                                                                                 

作为依赖被升级:
  NetworkManager.x86_64 1:1.12.0-10.el7_6                        NetworkManager-libnm.x86_64 1:1.12.0-10.el7_6                 NetworkManager-team.x86_64 1:1.12.0-10.el7_6                 
  NetworkManager-tui.x86_64 1:1.12.0-10.el7_6                    alsa-lib.x86_64 0:1.1.6-2.el7                                 audit.x86_64 0:2.8.4-4.el7                                   
  audit-libs.x86_64 0:2.8.4-4.el7                                bind-libs-lite.x86_64 32:9.9.4-73.el7_6                       bind-license.noarch 32:9.9.4-73.el7_6                        
  cryptsetup.x86_64 0:2.0.3-3.el7                                cryptsetup-libs.x86_64 0:2.0.3-3.el7                          efivar-libs.x86_64 0:36-11.el7_6.1                           
  firewalld.noarch 0:0.5.3-5.el7                                 firewalld-filesystem.noarch 0:0.5.3-5.el7                     genisoimage.x86_64 0:1.1.11-25.el7                           
  glib2.x86_64 0:2.56.1-2.el7                                    glusterfs.x86_64 0:3.12.2-18.el7                              glusterfs-api.x86_64 0:3.12.2-18.el7                         
  glusterfs-cli.x86_64 0:3.12.2-18.el7                           glusterfs-client-xlators.x86_64 0:3.12.2-18.el7               glusterfs-libs.x86_64 0:3.12.2-18.el7                        
  gsettings-desktop-schemas.x86_64 0:3.28.0-2.el7                gtk3.x86_64 0:3.22.30-3.el7                                   harfbuzz.x86_64 0:1.7.5-2.el7                                
  kpartx.x86_64 0:0.4.9-123.el7                                  krb5-libs.x86_64 0:1.15.1-37.el7_6                            libX11.x86_64 0:1.6.5-2.el7                                  
  libX11-common.noarch 0:1.6.5-2.el7                             libcgroup.x86_64 0:0.41-20.el7                                libreport-filesystem.x86_64 0:2.1.11-42.el7.centos           
  libselinux.x86_64 0:2.5-14.1.el7                               libselinux-python.x86_64 0:2.5-14.1.el7                       libselinux-utils.x86_64 0:2.5-14.1.el7                       
  libsemanage.x86_64 0:2.5-14.el7                                libsepol.x86_64 0:2.5-10.el7                                  libusal.x86_64 0:1.1.11-25.el7                               
  libwayland-client.x86_64 0:1.15.0-1.el7                        libwayland-cursor.x86_64 0:1.15.0-1.el7                       libwayland-server.x86_64 0:1.15.0-1.el7                      
  libxcb.x86_64 0:1.13-1.el7                                     linux-firmware.noarch 0:20180911-69.git85c5d90.el7            mokutil.x86_64 0:15-2.el7.centos                             
  nss.x86_64 0:3.36.0-7.1.el7_6                                  nss-sysinit.x86_64 0:3.36.0-7.1.el7_6                         nss-tools.x86_64 0:3.36.0-7.1.el7_6                          
  nss-util.x86_64 0:3.36.0-1.1.el7_6                             policycoreutils.x86_64 0:2.5-29.el7_6.1                       python-firewall.noarch 0:0.5.3-5.el7                         
  selinux-policy-targeted.noarch 0:3.13.1-229.el7_6.9            systemd.x86_64 0:219-62.el7_6.5                               systemd-libs.x86_64 0:219-62.el7_6.5                         
  systemd-sysv.x86_64 0:219-62.el7_6.5                           vte291.x86_64 0:0.52.2-2.el7                                 

替代:
  mesa-libwayland-egl.x86_64 0:17.2.3-8.20171019.el7                                                                                                                                         

完毕!

"GNOME Desktop" "Graphical Administration Tools" 顺利安装完成。

  

posted @ 2019-04-02 14:33  caoss  阅读(3247)  评论(1编辑  收藏